Snowboarding Forum - Snowboard Enthusiast Forums - View Single Post - Setting up snowboard problems, need help!
View Single Post
Old 03-08-2014, 01:57 PM   #2 (permalink)
West Baden Iron
-LIFETIME MEMBER-
 
West Baden Iron's Avatar
 
Join Date: Jan 2013
Location: West Baden Springs, IN
Posts: 276
Default

Quote:
Originally Posted by Tourn View Post
Hello!
Today I bought a rome reverb rocker 155w and burton custom bindings L.
I'm trying to set them up but am having some difficulty, I've heard a 15/15 stance is good because I jib frequently, but on my bindings there is no mark for 15 so I don't know what to do?:



Also when I was trying to install the bindings I put the screws in and did a couple of turns and found that it got very tight so I took them out to avoid threading. This is how much I can screw it in before it gets tight:



I don't know what to do, I don't want to screw my board?

Any help will be appreciated, thanks.
A little hard to see in the pics but here is my assessment.

Every tick on the disc is 3 degrees so you will be one tick from the 18 degree mark toward the 9 degree mark.

The screws should not get tight until they bottom out if you install them without the bindings. Make sure you are not cross threading them. You should be able to install them with very little pressure. Try a different hole and a different screw to make sure the threads aren't boogered on one of them. Inspect the screws to verify the threads are clean and uniform.

When you have the bindings installed, the screws engage about 2 or 3 threads before they start getting tight. To see if it is getting tight correctly, the bindings should start to get harder to move around. If the screw is getting tight but the bindings are still loose, then it has been cross threaded or may have a spot on the screw that you can file clean.
West Baden Iron is offline   Reply With Quote