Snowboarding Forum - Snowboard Enthusiast Forums - View Single Post - Burton Custom X Riding Issues
View Single Post
Old 12-24-2011, 09:03 PM   #9 (permalink)
jamesdthomas2
Member
 
jamesdthomas2's Avatar
 
Join Date: Nov 2011
Posts: 73
Default

Went out today. I did not see everyone post before I left. So, I moved my bindings all the way in and set up binding for a more directional feel. The temp was 31 degrees. I did not fall at all today (back to normal) but the board only rode ok. It felt a little sloppy but I am getting adjusted to that feel now.

qwezcx12, Thank you so much for the pics. You are awesome. I recently changed my foward lean in the binding because I couldn't ollie off boxes. When I changed this to no lean, I was able to jump without starting a heel edge (I don't know if I made sense there). I will check that out next time. I see a slight difference in high back angle (see pic). Older Cartels on more of a lean when set to zero. I think you may be on to something.

As far as edges go, I am completely lost. I did look at both edges, but I just see edges... lol. I do tune my own board but I just run the shapener along the side (I hope that's not a dumb comment). I did just pick up a diamond file from sheels. Do you think that makes a huge difference? Do you use is only on the bottom of the board or both bottom and sides?

Lonerider- I was thinking the same thing about my heel cup touching the snow. I wear a size 11.5 boot. The guy who sold me the board said I did not need a wide. So my Twin is a wide and the custom x is not. cx12 is riding a wide custom x. Do you think I made a mistake here? If so, what can I do to minimize this mistake? It's ok...I can take it... I think. It just 600 dollars down the drain
Attached Images
File Type: jpg IMG_0536.JPG (121.2 KB, 50 views)
File Type: jpg IMG_0534.JPG (119.4 KB, 46 views)
File Type: jpg IMG_0564.JPG (130.0 KB, 43 views)
jamesdthomas2 is offline   Reply With Quote