Snowboarding Forum - Snowboard Enthusiast Forums - View Single Post - K2 Cinch CTX 2012 cable problem & questions?
View Single Post
Old 02-17-2012, 03:36 PM   #4 (permalink)
sldrose
Junior Member
 
Join Date: Jan 2012
Posts: 9
Default

Quote:
Originally Posted by KIRKRIDER View Post
No...I had the same bindings since last season. Not a problem. A picture would help understand the problem? Sounds like the binding is not strapped right and you have less tension on the cable.
If the forward lean is at zero already I don't think there is a way to reduce it. No tricks, other than buying a low profile boot (Burton Driver X in my case) and setting the bindings correctly. I bend on my knees on a edge and pull the back lever...done. They work like a charm for me.
Thanks kirkrider,

yes the forward lean is already at zero, and i've increased the tension on the cable by using the allen key adjuster.
i've included a picture of where the cable slips out of the channel.

Yes, ive tried that trick to get in whilst kneeling, it works well (when the cable is working )

I've tried contacting K2 and they say that this is the first they've heard of this problem.
They want me to go through the dealer which is hard cause I bought the binding online in the US.
I'm in Calgary.

(FYI - I tried to get the binding through my local shops, but no K2 dealer in Calgary had stock and I was told that they couldn't get stock from K2 either)

cheers
Attached Images
File Type: jpg cinch_ctx_orange_CABLE.jpg (97.2 KB, 132 views)
sldrose is offline   Reply With Quote