Snowboarding Forum - Snowboard Enthusiast Forums - View Single Post - 2012/2013 Bataleon Evil Twin thread issues
View Single Post
Old 11-20-2012, 10:21 PM   #1 (permalink)
Lester86
Member
 
Join Date: Feb 2012
Posts: 75
Default 2012/2013 Bataleon Evil Twin thread issues

I recently purchased a 2012/2013 Bataleon Evil Twin board, this is my first Bataleon board I wanted to put it to the test this year I heard so many good things about the TBT tech so I wanted to give it a shot....

I received my board a few weeks back but didn't mess with it because the weather was not good over here (Midwest) I planned on head north last weekend and the Friday before I was putting the bindings on and I had a bit of difficulty putting the screws on the board they just didn't wanna catch the thread sorta speak (I used a screw driver, no power tools obviously). Felt tight I never had any issues with threads in any of my other boards (Lib Tech, Jones, Yes) so I didn't think much of it until it came time to tighten the screws down. I was tighten the screws down one by one and when I got the last screw I barely turned it 1/2 turn to 1 turn and it was tight. I couldn't reverse or tighten it felt welded on (first assumption was obvious cross thread).

I ended up having to drill the head of the screw off to get the binding off. When I got the binding off I saw that the screw was not angled or tilted like a cross thread screw would be. I called my retailer and that did a warranty swap and I got the new board in today.

I wanted to test out the threads so I tried screwing in a few brand new screws by hand to start them off as I always do. And its the same thing I have to work the screws in and out until they catch takes about 2-5 min to get each screw on. I got 8 of the 16 holes working but some are just not catching. I thought I was going crazy so I tried the same on all my other boards just to be sure and those go in fine smooth no issues catching. I tried to get a hold a Bataleon to report this. I also called all my local shops to see some possible solutions to loosen these same threads up. And it seems like everyone thinks im doing something wrong or whatever. Even with all the explaining, the only solution I heard was to use a tap (to trace the thread) but it was said that something like that isn't normally done on a new board.

Has anyone had this problem before with any board? possibly with Bataleon boards?
Lester86 is offline   Reply With Quote