Snowboarding Forum - Snowboard Enthusiast Forums - View Single Post - The Official Michigan Winter Thread
View Single Post
Old 11-29-2012, 10:12 AM   #2296 (permalink)
david_z
Official SBF Blogger
 
david_z's Avatar
 
Join Date: Dec 2009
Location: Detroit suburbs
Posts: 3,434
Blog Entries: 5
Default

Quote:
Originally Posted by chomps1211 View Post
The 2 runs they had were covered in hard packed "Iced Over Cement"! First go round,..? I crashed getting off the lift! (?????) Ok, obviously a bit rusty,.. got to the lip & started down,..
...crashed again less than 8 ft. from the top! Got up,.. pointed the board downslope & 2/3 rd's of the way down,..? On my ASS again!!!! WTF??
First couple years I snowboarded, and then after kind of hiatus during college, I was always *super* rusty on the first day of the season. It's like riding a bike, only you forgot how to ride the bike. Usually by the end of day 1 I was back in good shape though


Mt Holly -- I got there right about 3 (would've been earlier except I forgot my goggles and it was sunny so I went home to get them first. First few runs were icy. Not quite bulletproof, but really icy. After about 40 minutes they softened up a bit since there was some traffic on them. They had 3 total trails open and were only spinning the one high-speed quad chair, but it was never more than a 2-3 minute wait for a chair.

They had a few features set up: ride-on box about 1ft wide and maybe 10 ft long, a big corrugated redirect, and the shotgun rail. I was a bit hesitant to hit that rail on the first day but finally talked myself in to it, and it's just as smooth as I remember it from prior years. I had no major wipeouts but also didn't really try anything crazy yet
david_z is offline   Reply With Quote