Snowboarding Forum - Snowboard Enthusiast Forums - View Single Post - Rides' terrible customer service.
View Single Post
Old 12-18-2012, 12:19 PM   #2 (permalink)
hikeswithdogs
-LIFETIME MEMBER-
 
hikeswithdogs's Avatar
 
Join Date: Sep 2011
Location: Minnesota Summer--Utah Winter
Posts: 1,012
Blog Entries: 1
Default

Quote:
Originally Posted by h-d View Post
just read my email below.


You should try tightening your hardware before you go ride. This will solve the loosening/swiveling problem.

Thank You
Dan @ Ride

-----Original Message-----
Sent: Monday, December 17, 2012 9:01 AM
To: Ride Customer Service
Subject: Ride Snowboards: Customer Service


I purchased a Ride Kink and a pair of Rodeos about a month ago from Evo.com. I've only ridden it twice, and every 3-4 runs my right baseplate would get loose and my binding would swivel around. The left binding isn't as bad, but still does shift a bit. Please help me fix this problem.


like "oh so you mean to say the screws need to be tightened before I ride it?...are you sure?...cus im pretty sure ur supposed to just put sticky notes underneath to secure the binding"....ya no sh*t Horatio Caine i tightened it!
Weird I've never had an issue with K2 support in fact they have sent me new parts multiple times for free.

How on earth are your bindings plates coming loose every 3-4 times out I've never heard of such a thing.......do you have bad screws or something?

Try the blue locktite I guess?
__________________
makingfreshtracks.com
hikeswithdogs is offline   Reply With Quote