Snowboarding Forum - Snowboard Enthusiast Forums - View Single Post - Rides' terrible customer service.
View Single Post
Old 12-18-2012, 07:32 PM   #9 (permalink)
hktrdr
Banned
 
Join Date: Apr 2012
Posts: 1,966
Default

Quote:
Originally Posted by h-d View Post
just read my email below.


You should try tightening your hardware before you go ride. This will solve the loosening/swiveling problem.

Thank You
Dan @ Ride

-----Original Message-----
Sent: Monday, December 17, 2012 9:01 AM
To: Ride Customer Service
Subject: Ride Snowboards: Customer Service


I purchased a Ride Kink and a pair of Rodeos about a month ago from Evo.com. I've only ridden it twice, and every 3-4 runs my right baseplate would get loose and my binding would swivel around. The left binding isn't as bad, but still does shift a bit. Please help me fix this problem.


like "oh so you mean to say the screws need to be tightened before I ride it?...are you sure?...cus im pretty sure ur supposed to just put sticky notes underneath to secure the binding"....ya no sh*t Horatio Caine i tightened it!
I see no issue.

So you rode with a few screws loose (in every sense) and your bindings slipped. You asked CS and they told you to tighten the screws.

Unless there is some other symptom or some other information that you have not told us, the advice is completely correct and should fix the problem.

The only (very minor) complaint could be that the CS rep did not offer up any ideas over and above the basic answer (e.g., Loc-Tite) or ask any clarifying questions to check whether you left out any relevant information. But is a busy time of year and these guys get lots of silly questions like this, so cannot really blame him.
hktrdr is offline   Reply With Quote