Snowboarding Forum - Snowboard Enthusiast Forums - View Single Post - 2013 union binding >HELP<
View Single Post
post #103 of (permalink) Old 01-16-2013, 12:05 PM
Extremo
-LIFETIME MEMBER-
 
Extremo's Avatar
 
Join Date: Nov 2008
Location: NH
Posts: 3,571
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Eastžide View Post
im just going to go back to cartels or missions..since the missions are basically last years cartels. i just feel like if you have an issue with Union, you get bashed on for it. I'm clearly not the only one having these problems, and I'm sure not everyone is using the same boot as me.
I don't have a sullen life, but considering you're sitting in front of a computer also, what's your excuse? I'm letting people know my personal experience with my bindings..not everyone is made of money and can just go and grab a new set of bindings or boots when they're unhappy with the product.
Again, im not pissing over anything..if people asked me about my board or boot experience id be just as honest..for better or worse
I too have a job...which is why I'm sitting in front of a computer. So if you would get over it already, I've got billings that need to be done. Besides, aren't you also sitting in front a computer?

I'm just pointing out, that, in my experience with Union, which has been relatively extensive, I haven't been able to replicate this problem (which is why I'm more than happy with the product) and suspect that you may be doing something wrong, especially considering, in most cases of someone coming here for advice it turns out to be someone with little experience with the product and their problem is easily resolved. I just find it odd that I ride these same bindings 3-4 times a week and still haven't experienced any of these issues. Like Union said, you may be in that 1%.
Extremo is offline  
 
 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome