Snowboarding Forum - Snowboard Enthusiast Forums - View Single Post - Problem With Rome 390 Boss
View Single Post
post #9 of (permalink) Old 01-24-2013, 10:30 PM
Leo
-LIFETIME MEMBER-
 
Leo's Avatar
 
Join Date: Nov 2009
Location: Detroit Area
Posts: 6,230
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 0 Post(s)
There'a a thread of mine somewhere describing these exact problems and then my resolution to said problems... I'll summarize here:

Toe Strap issue - Make sure you put the ladders in the backmost slots

Ankle ratchets - After you strap in, make sure you slap the release tab down to ensure that it is in full lock position... alternatively, you can contact Rome about sending you spare ankle ratchets. The ones they send you will be basic metal, but work better IMO.

Forward Lean - request new highbacks. I've had mine come loose a couple of times. I usually ride with my pants over the highbacks though so maybe that helps?

Yes, Rome is littered with problems. But thanks to their customer service, I can continue to use mine without these issues anymore.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reviews and David Z's rants
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Leo is offline  
 
 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome