Snowboarding Forum - Snowboard Enthusiast Forums - View Single Post - Problem With Rome 390 Boss
View Single Post
Old 01-25-2013, 12:08 AM   #11 (permalink)
scotty100
Senior Member
 
Join Date: Apr 2012
Location: San Francisco
Posts: 473
Default

Quote:
Originally Posted by Leo View Post
There'a a thread of mine somewhere describing these exact problems and then my resolution to said problems... I'll summarize here:

Toe Strap issue - Make sure you put the ladders in the backmost slots

Ankle ratchets - After you strap in, make sure you slap the release tab down to ensure that it is in full lock position... alternatively, you can contact Rome about sending you spare ankle ratchets. The ones they send you will be basic metal, but work better IMO.

Forward Lean - request new highbacks. I've had mine come loose a couple of times. I usually ride with my pants over the highbacks though so maybe that helps?

Yes, Rome is littered with problems. But thanks to their customer service, I can continue to use mine without these issues anymore.
Yup, similar to my problems with a pair of 2012 Mobs. First run in them my ankle strap snapped off. Also, definitely make sure toe strap ladders in the furthest back slot. As for forward lean mechanism, I had them send me another after one of mine busted on my 2nd day in them, but it's a bad design and comes loose a lot when riding. I doubt I'll buy anymore Rome bindings. Good guys though. Can't fault their customer service and I like their boards.
scotty100 is offline   Reply With Quote