Snowboarding Forum - Snowboard Enthusiast Forums - View Single Post - Problem With Rome 390 Boss
View Single Post
Old 01-26-2013, 06:58 PM   #28 (permalink)
tdn
-LIFETIME MEMBER-
 
Join Date: Dec 2010
Location: Boston Suburbs
Posts: 383
Default

Quote:
Originally Posted by onthefence View Post
I have had these same problems with my 390 Boss.

- the toe adjuster (opposite the ratchet) releases and the toe strap comes loose. This happens mid-run and I am always afraid it will happen.

-the ratchet adjuster does not lock on when cranking the lever. This has happened to me three times, and each time it kinda just fixed itself but it took forever and kept me from riding completely

-high back adjuster coming loose. This happens frequently, and especially when I wipeout a couple times on a run.
Contact Rome if you haven't.

I had the issue show up again yesterday with my right toe cap, the side they didn't replace and also the side that was the least problematic. The side they did replace was only because that side came completely off and they sent me a new one. Haven't had a problem with that side at all yet. I'd prefer they send me another one for my right side so that it doesn't come off during a run and cause some serious problems. At least now both sides aren't popping loose so I'm not as worried as before, only the side they didn't replace.

Rode today too, no problems with the bindings but I took it easy with only a couple quick runs through the park.

If any of the guys at Rome are reading this, my guess is there was a bad batch? I don't know, but I'm willing to send right side in to have you guys check it out if you guys send me a replacement. Which I'll ask Carl for once he gets back to me. I did offer to buy a replacement but was declined, so it'll seem odd now that I'm requesting a flat out replacement or swap - but it is what it is as I'm still having issues.
tdn is offline   Reply With Quote