Snowboarding Forum - Snowboard Enthusiast Forums - View Single Post - Damn it alive!!!!!
View Single Post
Old 02-09-2013, 03:47 PM   #1 (permalink)
Joe Coffee
Senior Member
 
Joe Coffee's Avatar
 
Join Date: Dec 2012
Location: Alberta, Canada
Posts: 130
Default Damn it alive!!!!!

Ok so here is the problem. (NO THIS IS NOT ANOTHER UNION TOE STRAP THREAD)


I have a pair of Union forces (2013) and I ride a burton channel board. (2013 burton superhero). I bought the conversion disc for union bindings so they can be mounted on a burton channel board. I installed them and got the necessary hardware to mount them. (M6 hardware 13mm screws). HOWEVER when they are mounted and I ride with them they ROTATE. For instance they will be at 15 degrees at the top of the hill and then they will be at like 6 degrees at the bottom of the hill. My screws are tight and I mean TIGHT. They have been tightened with a screw driver not a power tool. The weird thing is the screws are still crazy tight when the binding rotates. The bindings do not slide up and down the channel though. They stay in place its just this f$$$$$ disc keeps rotating. This is really pissing me off because i have to go back to the chalet and take the bindings off and re align them losing a lot of time. So basically what can I do to fix this problem? I am at the point now were I want to just cement the damn disc to the board.



IMG_1686.JPG

IMG_1688.jpg

IMG_1689.jpg

IMG_1690.jpg


As you can see the bindings are shifting. They should be in line with the reference point on the board.
Attached Images
File Type: jpg IMG_1687.JPG (123.2 KB, 290 views)
__________________
Current Setup
Burton Super Hero 2013 151cm, Union Force Bindings 2013, Burton Hail Boots.

Last edited by Joe Coffee; 02-09-2013 at 03:58 PM.
Joe Coffee is offline   Reply With Quote