Snowboarding Forum - Snowboard Enthusiast Forums - View Single Post - Flow Binding 2013 Q & A
View Single Post
Old 04-08-2013, 10:17 PM   #448 (permalink)
jtg
-LIFETIME MEMBER-
 
Join Date: Dec 2012
Location: WA
Posts: 482
Default

Ok, well I just can't make these flows work. I thought I had it better but I definitely do not. I don't know if it's the design of the bindings, the shape of my boot, or just a bad combination of both. I've tweaked everything and cranked that thing so tight that I can't ride because it hurts, and I still get significant heel lift.

I think the problem might be that the upper part of the strap is too low on my boot, so increased tension isnt holding it back enough, its just pulling down. When you flex your ankles and lean forward, no matter how tight I make it, the heel still comes up. After I lock it in as tightly as I can, at the bottom of the run there is a ton of snow under my heel. The back of my boots also has a rubber strip, which makes kind of a squeak sound as it rubs against the binding, so I know it's lifting right away.

Maybe next season I'll try on some flow boots and see if they work better. I have to assume that's what they were designed with and maybe my boot just varies in shape too much. Either way I'll have to either buy new bindings or new boots, so we'll see what works. To be fair, I haven't tried these boots in other bindings yet...maybe it will be the case that they lift in those too.

Last edited by jtg; 04-08-2013 at 10:21 PM.
jtg is offline   Reply With Quote