2013 390 boss toe strap breakage. - Snowboarding Forum - Snowboard Enthusiast Forums
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 (permalink) Old 02-24-2014, 04:48 PM Thread Starter
Senior Member
 
Dago91's Avatar
 
Join Date: Mar 2013
Location: Zurich,CH
Posts: 235
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2013 390 boss toe strap breakage.

Well on my 10th day of riding these bindings I came off a lift and clipped in.. halfway down a sweet little tree run I felt a weird feeling on my lead foot like less control. Turns out somehow my toestrap broke. After getting home I inspected the other toestrap and noticed the thick plastic was ripping on the bottom.

So I am a-little bummed at this point because the bindings are already going south after my 10th day on them

I contacted rome thru the warranty page and said urgent since I can't ride these right now. Has anyone had any experience with rome warranty? After submitting my ticket it did not say anything like received or sent it just went back to the main page.. is this normal? how long does it take them to get back in touch with you on an urgent ticket? Do they have a phone number for warranty?

I requested they send me two of the new toe straps on the 14/15 model which I believe are the targa straps which are more durable.

Here are some pics.. really like these bindings but will be riding my cartels until fixed.



here are some pics.. I will be riding my cartels until fixed.
Dago91 is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 02-25-2014, 01:29 AM
Veteran Member
 
scotty100's Avatar
 
Join Date: Apr 2012
Location: San Francisco
Posts: 759
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 69 Post(s)
There are many posts on here last couple of years regards poor quality of various Rome bindings. They used to have a rep on here who was quite responsive and helpful but disappeared when the bad quality posts started to increase. Toe straps, ankle straps and forward lean adjusters are all problem areas across different models.
scotty100 is offline  
post #3 of 17 (permalink) Old 02-26-2014, 07:54 AM Thread Starter
Senior Member
 
Dago91's Avatar
 
Join Date: Mar 2013
Location: Zurich,CH
Posts: 235
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Dago91 View Post
I contacted rome thru the warranty page and said urgent since I can't ride these right now. Has anyone had any experience with rome warranty? After submitting my ticket it did not say anything like received or sent it just went back to the main page.. is this normal? how long does it take them to get back in touch with you on an urgent ticket?.
Ok.. so updating this to maybe help out anyone with future questions about the rome warranty page, because no one seemed to know.

-As I said when I submitted my ticket it gave me no indication that the ticket was received. I resubmitted my ticket today and here is what should happen.

- After submitting you get redirected to a page that has your ticket number and a description of your problem. if you go in to history you have a ticket with the status open.

-Simultaneously you will also receive an email from rome that says they have received the ticket and will be back with you shortly.

I believe something was wrong with their ticket warranty system the first time I submitted a ticket. Hope this helps anyone in the future and will keep you updated on how fast the turn around will be on romes end.
Dago91 is offline  
post #4 of 17 (permalink) Old 02-26-2014, 08:28 AM
Junior Member
 
Join Date: Nov 2012
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
hey man, I had basically the same experience. I have the 12/13 390 boss, right toe strap got hooked during a tree run and unclipped, gone.

My local shop carries assorted binding parts and they sold me last years toe strap for like $10. If you don't mind it looking a bit different, it works the same exact way.

I'm gonna go with a pair of Union's after this season
PayneSkillet is offline  
post #5 of 17 (permalink) Old 02-26-2014, 12:12 PM
tdn
-LIFETIME MEMBER-
 
Join Date: Dec 2010
Location: Boston Suburbs
Posts: 391
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
That's one of the issues I had with my 2012 390 Boss bindings too, after a run it unhooked and disappeared. I kind of saw it coming.. it would unhook by itself constantly making for some potentially dangerous situations.

Contact Rome, they'll probably send you a replacement.
tdn is offline  
post #6 of 17 (permalink) Old 02-26-2014, 12:29 PM Thread Starter
Senior Member
 
Dago91's Avatar
 
Join Date: Mar 2013
Location: Zurich,CH
Posts: 235
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by tdn View Post
That's one of the issues I had with my 2012 390 Boss bindings too, after a run it unhooked and disappeared. I kind of saw it coming.. it would unhook by itself constantly making for some potentially dangerous situations.

Contact Rome, they'll probably send you a replacement.
@tdn and @wiredsport thanks again for your help on this.

For me the only thing that I see besides the toe strap issue are the following..

-paint chipping issue.. I have the green color-way -- 20114/15 has completely addressed this issue.
-the graphics in the foam auto cant just diminish away.. honestly thou that is too be expected with that type of material -- again 2014/ has completely addressed this issue with one solid footbed with better material used on the footbed.

Overall I really like these bindings.. the ankle strap is nice and plush.. the buckles and ladders are smooth. highback seems good after I fixed th lean adjuster. Personally I like a company that listens to the feedback of the riders and addresses problems the way rome seems to do year in and year out.

Last edited by Dago91; 02-26-2014 at 12:39 PM.
Dago91 is offline  
post #7 of 17 (permalink) Old 02-26-2014, 12:48 PM
Veteran Member
 
redlude97's Avatar
 
Join Date: Jan 2008
Location: Seattle/Portland
Posts: 1,132
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
I've been disappointed in my 13 bosses as well. I've now broken 2 ankle strap buckles. The original and the replacement they sent me. In 3 days of use. Right now they have some generic buckle I got from the resort shop. My old 390's from 08 have close to 50 days on them and are still going strong so I don't know if its a fluke or worse manufacturing because the design appears the same.
redlude97 is offline  
post #8 of 17 (permalink) Old 02-26-2014, 01:12 PM
Veteran Member
 
ThunderChunky's Avatar
 
Join Date: Oct 2011
Location: Kissing Bridge
Posts: 1,817
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
This happens to almost all bindings. Happened to my Mobs the other day and my friends Technines the day after. Just contact Rome. I had an out of warranty pair of bindings and they overnight shipped me a new highback.

They may have gotten dramatically shittier in the last two years I don't know, but chances are you're just a shitty unlucky situation. I haven't had this happen with my 390s, but I've barely ridden them. Hope this don't happen to me.

Quote:
Originally Posted by 2hipp4u View Post
Im all for having fun, showing your tits and getting fucked up on a river float but it can be done without being a pig.
ThunderChunky is offline  
post #9 of 17 (permalink) Old 02-26-2014, 01:35 PM
Senior Member
 
Deimus85's Avatar
 
Join Date: Dec 2012
Location: 609
Posts: 400
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Rome has always had awesome customer service when I have dealt with them.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Deimus85 is offline  
post #10 of 17 (permalink) Old 02-26-2014, 02:21 PM
Junior Member
 
Join Date: Jul 2012
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My 2013 Targas toe straps were broken as well. Sent them a message and in a couple of days Mike G. from romesnowboards sent me a tracking number. Amazing CS.
msq_sf is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome