Ride spi binding and boot setup need advice - Snowboarding Forum - Snowboard Enthusiast Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-07-2011, 09:05 PM Thread Starter
Junior Member
 
Join Date: Mar 2011
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Ride spi binding and boot setup need advice

Bought an arbor element board and a pair of ride spi bindings 08/09 model, question is these are stiff bindings so what boots should i be looking at? I was thinking about burton ruler but they are also pretty stiff, would the burton hail boots work better and should i get stiff or mid stiff boots with these bindings as they are already pretty stiff. I will be doing free riding, all mountain no park and alot of carving. Not sure which section i should put this question in so its posted in both boots and bindings section.
ivanivz is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome