Snowboarding Forum - Snowboard Enthusiast Forums

Snowboarding Forum - Snowboard Enthusiast Forums (http://www.snowboardingforum.com/forum.php)
-   Bindings (http://www.snowboardingforum.com/bindings/)
-   -   Rome 390 Bosses ankle strap popping off? (http://www.snowboardingforum.com/bindings/46127-rome-390-bosses-ankle-strap-popping.html)

Marumm 01-30-2012 03:59 PM

Rome 390 Bosses ankle strap popping off?
 
I recently picked up a pair of Rome 390 Bosses for the canted footbeds, which are really comfortable and have been great on my knees so far. However, each of the two times I've taken them up this year, the ankle straps have unfastened, seemingly spontaneously, three times. It's happened twice on my front foot, and once on the rear foot, so it's at least not just a single crappy ratchet.

The second time it happened, I was on the lift, a good 40+ feet over the ground, when the guy next to me looks over and says, "Uhh dude, you know your binding's undone?" I look down, and sure enough, the only thing keeping my board attached to my feet is the toe strap on my left foot. Scary.

So for those with this binding- have you noticed that the release mechanism is extremely touchy? My old P1.1s (which I'm going back to) certainly need a lot more effort to get them to release. The Rome ones just seem to need a teeny tap and they're off. It makes me wonder if I'm missing a locking or fastening mechanism on the things.

lonerider 01-30-2012 04:21 PM

Quote:

Originally Posted by Marumm (Post 475899)
I recently picked up a pair of Rome 390 Bosses for the canted footbeds, which are really comfortable and have been great on my knees so far. However, each of the two times I've taken them up this year, the ankle straps have unfastened, seemingly spontaneously, three times. It's happened twice on my front foot, and once on the rear foot, so it's at least not just a single crappy ratchet.

The second time it happened, I was on the lift, a good 40+ feet over the ground, when the guy next to me looks over and says, "Uhh dude, you know your binding's undone?" I look down, and sure enough, the only thing keeping my board attached to my feet is the toe strap on my left foot. Scary.

So for those with this binding- have you noticed that the release mechanism is extremely touchy? My old P1.1s (which I'm going back to) certainly need a lot more effort to get them to release. The Rome ones just seem to need a teeny tap and they're off. It makes me wonder if I'm missing a locking or fastening mechanism on the things.

Have last year's Rome 390 BOSS... ~30 days of riding and haven't notice the ankle strap coming loose (I do have problems getting the toe-strap to sit well on the toe of my boot (it actually can come off my boot sometimes). I ought to fiddle with the adjustments more to try and get it to work.

borborygmii 01-30-2012 05:59 PM

I had similar problems with both the ankle and toe straps on my Targas. I solved the ankle strap problem for good with plastic cable ties. I use cable ties on the top straps, but they don't stay on as well...tend to come off if I wipe out hard.

extra0 01-30-2012 10:51 PM

I had a bit of a problem with my targas, but it was usually only when my pants leg cuff would freeze/curl up that it would grab the release lever. The Rome ratchets are high quality, but they need to shorten up that release lever (like burton has)

jliu 01-31-2012 09:08 AM

Quote:

Originally Posted by Marumm (Post 475899)
I recently picked up a pair of Rome 390 Bosses for the canted footbeds, which are really comfortable and have been great on my knees so far. However, each of the two times I've taken them up this year, the ankle straps have unfastened, seemingly spontaneously, three times. It's happened twice on my front foot, and once on the rear foot, so it's at least not just a single crappy ratchet.

The second time it happened, I was on the lift, a good 40+ feet over the ground, when the guy next to me looks over and says, "Uhh dude, you know your binding's undone?" I look down, and sure enough, the only thing keeping my board attached to my feet is the toe strap on my left foot. Scary.

So for those with this binding- have you noticed that the release mechanism is extremely touchy? My old P1.1s (which I'm going back to) certainly need a lot more effort to get them to release. The Rome ones just seem to need a teeny tap and they're off. It makes me wonder if I'm missing a locking or fastening mechanism on the things.

Man...i hate to be "that guy" on the board that always chimes in on the same issue...but your complains are word for word. I have targas and countless rachets later...still the same issue. But yes, I feel you pain. The burton rachets release just as easy...BUT the biggest design difference is that the tab is not positioned in a way that it can easily be knocked open. With the burtons...you have to kinda pull the lever perpendicular to the ladder and then up. No pant cuff or whatever will perform that motion when you're riding.

I am somewhat happy that others experience the same thing so i dont feel crazy...but i feel terrible as well cause its the most frustrating and dangerous thing ever :(

Slush Puppie 02-01-2012 02:52 PM

I had a problem last week that the ratchets on my 2012 390 Boss wouldn't engage. Only happened a couple of times but when it did the only way I could get them to catch was to manually press the catch into the ladder with my thumb - and hope for the best it held.

f1 tech 02-02-2012 03:23 PM

I have a set of 2011 Rome SDS bindings on my Lib Tech and the upper strap do come loose. I sometimes have to stop midway on my run to tighten it. Man, I'm getting annoyed and may just ditch them and go for some other brand. I'm done with Rome bindings.

Tech420 01-04-2013 08:12 PM

Bumping an old thread looking for a solution. I am having the same issue on my brand new 2013's. I want to say it's because the latch is sometimes not pressed all the way down, but then again why should I make sure to press the latch all the way down after strapping up? I too had a scary experience on the lift and numerous times down runs. I have noticed it sometimes happens after I tighten my bindings mid-run so it makes me think it may be from not pushing the tab flat.

tdn 01-04-2013 11:48 PM

Same problem here, happened when I first got them, contacted Rome, they seemed concerned and said they never heard of the issue. I stopped contacting them because the problem went away.. until the last few times out, in fact, today my ankle strap went missing completely after popping off.. going to contact them again and hope to get it replaced.

Once I get the bindings up and going again, I'm going to have to zip tie them I guess. I think the bindings go great with my go to board, so I'm really trying to not be upset about this, but it's so damn annoying.


All times are GMT -5. The time now is 12:00 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2