Rome 390 Bosses ankle strap popping off? - Snowboarding Forum - Snowboard Enthusiast Forums
SnowboardingForum.com is the premier Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-30-2012, 03:59 PM   #1 (permalink)
Junior Member
 
Marumm's Avatar
 
Join Date: Jan 2010
Posts: 17
Default Rome 390 Bosses ankle strap popping off?

I recently picked up a pair of Rome 390 Bosses for the canted footbeds, which are really comfortable and have been great on my knees so far. However, each of the two times I've taken them up this year, the ankle straps have unfastened, seemingly spontaneously, three times. It's happened twice on my front foot, and once on the rear foot, so it's at least not just a single crappy ratchet.

The second time it happened, I was on the lift, a good 40+ feet over the ground, when the guy next to me looks over and says, "Uhh dude, you know your binding's undone?" I look down, and sure enough, the only thing keeping my board attached to my feet is the toe strap on my left foot. Scary.

So for those with this binding- have you noticed that the release mechanism is extremely touchy? My old P1.1s (which I'm going back to) certainly need a lot more effort to get them to release. The Rome ones just seem to need a teeny tap and they're off. It makes me wonder if I'm missing a locking or fastening mechanism on the things.
Marumm is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-30-2012, 04:21 PM   #2 (permalink)
Veteran Member
 
lonerider's Avatar
 
Join Date: Apr 2009
Location: Mountain View, CA
Posts: 947
Default

Quote:
Originally Posted by Marumm View Post
I recently picked up a pair of Rome 390 Bosses for the canted footbeds, which are really comfortable and have been great on my knees so far. However, each of the two times I've taken them up this year, the ankle straps have unfastened, seemingly spontaneously, three times. It's happened twice on my front foot, and once on the rear foot, so it's at least not just a single crappy ratchet.

The second time it happened, I was on the lift, a good 40+ feet over the ground, when the guy next to me looks over and says, "Uhh dude, you know your binding's undone?" I look down, and sure enough, the only thing keeping my board attached to my feet is the toe strap on my left foot. Scary.

So for those with this binding- have you noticed that the release mechanism is extremely touchy? My old P1.1s (which I'm going back to) certainly need a lot more effort to get them to release. The Rome ones just seem to need a teeny tap and they're off. It makes me wonder if I'm missing a locking or fastening mechanism on the things.
Have last year's Rome 390 BOSS... ~30 days of riding and haven't notice the ankle strap coming loose (I do have problems getting the toe-strap to sit well on the toe of my boot (it actually can come off my boot sometimes). I ought to fiddle with the adjustments more to try and get it to work.
lonerider is offline   Reply With Quote
Old 01-30-2012, 05:59 PM   #3 (permalink)
Member
 
borborygmii's Avatar
 
Join Date: Feb 2011
Posts: 71
Default

I had similar problems with both the ankle and toe straps on my Targas. I solved the ankle strap problem for good with plastic cable ties. I use cable ties on the top straps, but they don't stay on as well...tend to come off if I wipe out hard.
borborygmii is offline   Reply With Quote
Old 01-30-2012, 10:51 PM   #4 (permalink)
Veteran Member
 
extra0's Avatar
 
Join Date: Jan 2010
Location: CA
Posts: 624
Default

I had a bit of a problem with my targas, but it was usually only when my pants leg cuff would freeze/curl up that it would grab the release lever. The Rome ratchets are high quality, but they need to shorten up that release lever (like burton has)
extra0 is offline   Reply With Quote
Old 01-31-2012, 09:08 AM   #5 (permalink)
Senior Member
 
jliu's Avatar
 
Join Date: Jan 2009
Location: Toronto
Posts: 272
Default

Quote:
Originally Posted by Marumm View Post
I recently picked up a pair of Rome 390 Bosses for the canted footbeds, which are really comfortable and have been great on my knees so far. However, each of the two times I've taken them up this year, the ankle straps have unfastened, seemingly spontaneously, three times. It's happened twice on my front foot, and once on the rear foot, so it's at least not just a single crappy ratchet.

The second time it happened, I was on the lift, a good 40+ feet over the ground, when the guy next to me looks over and says, "Uhh dude, you know your binding's undone?" I look down, and sure enough, the only thing keeping my board attached to my feet is the toe strap on my left foot. Scary.

So for those with this binding- have you noticed that the release mechanism is extremely touchy? My old P1.1s (which I'm going back to) certainly need a lot more effort to get them to release. The Rome ones just seem to need a teeny tap and they're off. It makes me wonder if I'm missing a locking or fastening mechanism on the things.
Man...i hate to be "that guy" on the board that always chimes in on the same issue...but your complains are word for word. I have targas and countless rachets later...still the same issue. But yes, I feel you pain. The burton rachets release just as easy...BUT the biggest design difference is that the tab is not positioned in a way that it can easily be knocked open. With the burtons...you have to kinda pull the lever perpendicular to the ladder and then up. No pant cuff or whatever will perform that motion when you're riding.

I am somewhat happy that others experience the same thing so i dont feel crazy...but i feel terrible as well cause its the most frustrating and dangerous thing ever
jliu is offline   Reply With Quote
Old 02-01-2012, 02:52 PM   #6 (permalink)
Senior Member
 
Slush Puppie's Avatar
 
Join Date: Aug 2011
Location: French Alps
Posts: 317
Default

I had a problem last week that the ratchets on my 2012 390 Boss wouldn't engage. Only happened a couple of times but when it did the only way I could get them to catch was to manually press the catch into the ladder with my thumb - and hope for the best it held.
Slush Puppie is offline   Reply With Quote
Old 02-02-2012, 03:23 PM   #7 (permalink)
Junior Member
 
f1 tech's Avatar
 
Join Date: Jan 2010
Location: Washington, D.C.
Posts: 16
Default

I have a set of 2011 Rome SDS bindings on my Lib Tech and the upper strap do come loose. I sometimes have to stop midway on my run to tighten it. Man, I'm getting annoyed and may just ditch them and go for some other brand. I'm done with Rome bindings.
f1 tech is offline   Reply With Quote
Old 01-04-2013, 08:12 PM   #8 (permalink)
-LIFETIME MEMBER-
 
Tech420's Avatar
 
Join Date: Jun 2011
Posts: 516
Default

Bumping an old thread looking for a solution. I am having the same issue on my brand new 2013's. I want to say it's because the latch is sometimes not pressed all the way down, but then again why should I make sure to press the latch all the way down after strapping up? I too had a scary experience on the lift and numerous times down runs. I have noticed it sometimes happens after I tighten my bindings mid-run so it makes me think it may be from not pushing the tab flat.
Tech420 is offline   Reply With Quote
Old 01-04-2013, 11:48 PM   #9 (permalink)
tdn
-LIFETIME MEMBER-
 
Join Date: Dec 2010
Location: Boston Suburbs
Posts: 365
Default

Same problem here, happened when I first got them, contacted Rome, they seemed concerned and said they never heard of the issue. I stopped contacting them because the problem went away.. until the last few times out, in fact, today my ankle strap went missing completely after popping off.. going to contact them again and hope to get it replaced.

Once I get the bindings up and going again, I'm going to have to zip tie them I guess. I think the bindings go great with my go to board, so I'm really trying to not be upset about this, but it's so damn annoying.
tdn is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:24 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
VerticalSports
Baseball Forum Golf Forum Boxing Forum Snowmobile Forum
Basketball Forum Soccer Forum MMA Forum PWC Forum
Football Forum Cricket Forum Wrestling Forum ATV Forum
Hockey Forum Volleyball Forum Paintball Forum Snowboarding Forum
Tennis Forum Rugby Forums Lacrosse Forum Skiing Forums