Problem With Rome 390 Boss - Snowboarding Forum - Snowboard Enthusiast Forums
SnowboardingForum.com is the premier Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-24-2013, 07:58 PM   #1 (permalink)
Member
 
Join Date: Nov 2012
Posts: 53
Default Problem With Rome 390 Boss

Hello all,

I have a pair of 2011/2012 390 Boss's

I have had a few problems with them:

-my toe straps has opened up a few times while riding (not the latch but the other part of the strap thats is not suppose to open)

-the latch on my ankle strap has opened up while riding.

-the thing that can adjust the highback angle will turn while riding (which I have fixed by tightening it but it will turn causing my angle to shit while riding)

Has anyone else had these problems or am I doing something really wrong??

I have only used them about 6 times so far. I got them the start of this season.



Thanks
dopeythatme is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-24-2013, 08:02 PM   #2 (permalink)
Veteran Member
 
MarshallV82's Avatar
 
Join Date: Apr 2011
Location: Golden, CO
Posts: 758
Default

I bought some in 2012, they just collect dust now. They're good bindings when they are not falling apart.. haha. I like my Cartels way better.


Call Rome though, they have badass customer service compared to most companies you deal with. get some pictures and document your problems. They will hook you up!
MarshallV82 is offline   Reply With Quote
Old 01-24-2013, 08:07 PM   #3 (permalink)
Veteran Member
 
lonerider's Avatar
 
Join Date: Apr 2009
Location: Mountain View, CA
Posts: 947
Default

Quote:
Originally Posted by dopeythatme View Post
Hello all,

I have a pair of 2011/2012 390 Boss's

I have had a few problems with them:

-my toe straps has opened up a few times while riding (not the latch but the other part of the strap thats is not suppose to open)

-the latch on my ankle strap has opened up while riding.

-the thing that can adjust the highback angle will turn while riding (which I have fixed by tightening it but it will turn causing my angle to shit while riding)

Has anyone else had these problems or am I doing something really wrong??

I have only used them about 6 times so far. I got them the start of this season.



Thanks
I had I think the same model (blue/white) Rome 390.

1. The toestrap would flip off, I think this was because it never fit my boot correctly and less because it was loosening.
2. Yes the forward lean adjuster on the highback occasionally turn unless I tighten it.
3. My boot would occasionally ride up on the outer ridge of the binding by the lateral toestrap.

In the end, I traded them in for a pair of Burton CO2 that were on hyper-discount and I like those a lot better.
lonerider is offline   Reply With Quote
Old 01-24-2013, 08:15 PM   #4 (permalink)
Member
 
Join Date: Nov 2012
Posts: 53
Default

Quote:
Originally Posted by lonerider View Post
I had I think the same model (blue/white) Rome 390.

1. The toestrap would flip off, I think this was because it never fit my boot correctly and less because it was loosening.
2. Yes the forward lean adjuster on the highback occasionally turn unless I tighten it.
3. My boot would occasionally ride up on the outer ridge of the binding by the lateral toestrap.

In the end, I traded them in for a pair of Burton CO2 that were on hyper-discount and I like those a lot better.

Did you try contacting the Rome and telling them this problem?


And its not that it would flip off.
The strap disengages its self while riding.
dopeythatme is offline   Reply With Quote
Old 01-24-2013, 08:19 PM   #5 (permalink)
Veteran Member
 
lonerider's Avatar
 
Join Date: Apr 2009
Location: Mountain View, CA
Posts: 947
Default

Quote:
Originally Posted by dopeythatme View Post
Did you try contacting the Rome and telling them this problem?

And its not that it would flip off.
The strap disengages its self while riding.
I never had an issue with the strap itself disengaging like you - hence I never called them about it.
lonerider is offline   Reply With Quote
Old 01-24-2013, 08:20 PM   #6 (permalink)
Member
 
Join Date: Nov 2012
Posts: 53
Default

Quote:
Originally Posted by MarshallV82 View Post
I bought some in 2012, they just collect dust now. They're good bindings when they are not falling apart.. haha. I like my Cartels way better.


Call Rome though, they have badass customer service compared to most companies you deal with. get some pictures and document your problems. They will hook you up!
I want to call them and be like "these bindings are falling apart, I'm afraid to use them now and had to use my old burton mission because I have fallen out of them several times."
dopeythatme is offline   Reply With Quote
Old 01-24-2013, 09:04 PM   #7 (permalink)
tdn
-LIFETIME MEMBER-
 
Join Date: Dec 2010
Location: Boston Suburbs
Posts: 349
Default

I had the same problem with the static side popping off and releasing my feet. This happened while landing from a jump, scared the shit out of me upon landing and could have been very serious. I still get worried when going off a jump, I suppose I shouldn't risk it... I had both feet pop out on a flat 180, literally on my first or second run on the bindings. It's happened about 7 times now. I can go weeks without a problem, then have it occur a few times in one week. I've been super careful, my buddies and eye kept a close eye and there's nothing catching onto the latch. We're very certain the latches have been popping upon landings.

Make sure you contact Rome. I told them about the issue and they told me they never heard of that problem.. but when I did some searching I was able to find plenty of people with the same issue.

I eventually lost one of my straps (the most problematic side), which Carl replaced. I had white 390's with a white buckle, he sent me black straps with black buckle.. which lowers the value of the bindings for when I sell them. Not a huge deal, but it would of been nice if he at least tried matching it with what I had. I spoke to someone else at Rome who said they always try matching... so I'm not sure what happened then.

Anyway, I had another issue with my foot bed that I was willing to pay to fix, it wasn't a warranty issue and a fault of a friend of mine, but the guy on the phone told me to contact Carl anyway. So I sent him an email and he hasn't gotten back to me since.

Rome seems like a good group of guys, but I think this might be my last product from them. I'm just hoping my other strap doesn't randomly pop open.

Sorry about the rant.. my point was to contact Carl about the issue of your bindings popping, because I believe it was him who said he never heard of the issue.

Last edited by tdn; 01-24-2013 at 09:13 PM.
tdn is offline   Reply With Quote
Old 01-24-2013, 09:47 PM   #8 (permalink)
Member
 
Join Date: Nov 2012
Posts: 53
Default

Quote:
Originally Posted by tdn View Post
I had the same problem with the static side popping off and releasing my feet. This happened while landing from a jump, scared the shit out of me upon landing and could have been very serious. I still get worried when going off a jump, I suppose I shouldn't risk it... I had both feet pop out on a flat 180, literally on my first or second run on the bindings. It's happened about 7 times now. I can go weeks without a problem, then have it occur a few times in one week. I've been super careful, my buddies and eye kept a close eye and there's nothing catching onto the latch. We're very certain the latches have been popping upon landings.

Make sure you contact Rome. I told them about the issue and they told me they never heard of that problem.. but when I did some searching I was able to find plenty of people with the same issue.

I eventually lost one of my straps (the most problematic side), which Carl replaced. I had white 390's with a white buckle, he sent me black straps with black buckle.. which lowers the value of the bindings for when I sell them. Not a huge deal, but it would of been nice if he at least tried matching it with what I had. I spoke to someone else at Rome who said they always try matching... so I'm not sure what happened then.

Anyway, I had another issue with my foot bed that I was willing to pay to fix, it wasn't a warranty issue and a fault of a friend of mine, but the guy on the phone told me to contact Carl anyway. So I sent him an email and he hasn't gotten back to me since.

Rome seems like a good group of guys, but I think this might be my last product from them. I'm just hoping my other strap doesn't randomly pop open.

Sorry about the rant.. my point was to contact Carl about the issue of your bindings popping, because I believe it was him who said he never heard of the issue.

please send me his email. I will contact them. they are sending me a new tor strap but still I amvery annoyed.
dopeythatme is offline   Reply With Quote
Old 01-24-2013, 10:30 PM   #9 (permalink)
Leo
-LIFETIME MEMBER-
 
Leo's Avatar
 
Join Date: Nov 2009
Location: Detroit Area
Posts: 6,230
Default

There'a a thread of mine somewhere describing these exact problems and then my resolution to said problems... I'll summarize here:

Toe Strap issue - Make sure you put the ladders in the backmost slots

Ankle ratchets - After you strap in, make sure you slap the release tab down to ensure that it is in full lock position... alternatively, you can contact Rome about sending you spare ankle ratchets. The ones they send you will be basic metal, but work better IMO.

Forward Lean - request new highbacks. I've had mine come loose a couple of times. I usually ride with my pants over the highbacks though so maybe that helps?

Yes, Rome is littered with problems. But thanks to their customer service, I can continue to use mine without these issues anymore.
__________________
www.aGNARchy.com Reviews and David Z's rants
Leo is offline   Reply With Quote
Old 01-24-2013, 10:31 PM   #10 (permalink)
tdn
-LIFETIME MEMBER-
 
Join Date: Dec 2010
Location: Boston Suburbs
Posts: 349
Default

I don't know if this goes directly to him, but this is from what he's been contacting me.

help@warranty.romesnowboards.com
tdn is offline   Reply With Quote
Reply

Tags
390 boss, ankle strap opening, boss, problems, rome

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:59 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
VerticalSports
Baseball Forum Golf Forum Boxing Forum Snowmobile Forum
Basketball Forum Soccer Forum MMA Forum PWC Forum
Football Forum Cricket Forum Wrestling Forum ATV Forum
Hockey Forum Volleyball Forum Paintball Forum Snowboarding Forum
Tennis Forum Rugby Forums Lacrosse Forum Skiing Forums