Forum Bindings...any issues?!?!? - Snowboarding Forum - Snowboard Enthusiast Forums
SnowboardingForum.com is the premier Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-02-2013, 09:56 PM   #1 (permalink)
-LIFETIME MEMBER-
 
jwelsh83's Avatar
 
Join Date: Jan 2013
Posts: 231
Default Forum Bindings...any issues?!?!?

Hey guys, I've got some Forum Shaka bindings and didn't know if anybody else has had issues with their Forum high backs, or even Shakas. Was out the other day and a screw that allows you to adjust the position of the high back came out at some point. Lost the screw, bracket on the inside of the binding and the color tab that covers up the other positional holes...I called Forum and their sending me new hardware. Didn't know if anybody else had issues...
jwelsh83 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:09 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
VerticalSports
Baseball Forum Golf Forum Boxing Forum Snowmobile Forum
Basketball Forum Soccer Forum MMA Forum PWC Forum
Football Forum Cricket Forum Wrestling Forum ATV Forum
Hockey Forum Volleyball Forum Paintball Forum Snowboarding Forum
Tennis Forum Rugby Forums Lacrosse Forum Skiing Forums