Canting and Binding Performance Issues - Page 4 - Snowboarding Forum - Snowboard Enthusiast Forums
SnowboardingForum.com is the premier Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-06-2013, 11:02 PM   #31 (permalink)
Senior Member
 
Cyfer's Avatar
 
Join Date: Feb 2013
Posts: 118
Default

Looks a lot better more even edge to edge
Attached Images
File Type: jpg image.jpg (109.4 KB, 148 views)
Cyfer is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-06-2013, 11:03 PM   #32 (permalink)
Senior Member
 
Cyfer's Avatar
 
Join Date: Feb 2013
Posts: 118
Default

Increased the forward lean to four clicks so now the high back is flush against the boot.
Attached Images
File Type: jpg image.jpg (93.1 KB, 148 views)
Cyfer is offline   Reply With Quote
Old 03-07-2013, 01:28 PM   #33 (permalink)
-LIFETIME MEMBER-
 
Extremo's Avatar
 
Join Date: Nov 2008
Location: NH
Posts: 3,340
Default

You shouldn't have your highbacks in the front holes. They need to be back against the heel loop. You're probably losing all of your heelside leverage because clearly your boot is too far forward in the binding and over the board.
Extremo is offline   Reply With Quote
Old 03-07-2013, 04:53 PM   #34 (permalink)
Veteran Member
 
timmytard's Avatar
 
Join Date: Mar 2009
Location: I can see Santa shoveling his driveway
Posts: 2,053
Default

Quote:
Originally Posted by Extremo View Post
You shouldn't have your highbacks in the front holes. They need to be back against the heel loop. You're probably losing all of your heelside leverage because clearly your boot is too far forward in the binding and over the board.
Ya totally agree.

You should either move both back one hole or just the one so the highbacks are inline with the edge of your board.

Move the right side of your left bindings highback back one hole.

That's also why your forward lean had to be set so far forward

Once you put the highback where it's supposed to go, you'll have to reset the forward lean .

Now you should be ready to rock


TT
__________________
If whatever doesn't kill you, only makes you stronger.

Then I am so close to immortality
timmytard is offline   Reply With Quote
Old 03-07-2013, 05:30 PM   #35 (permalink)
Senior Member
 
lcstriker07's Avatar
 
Join Date: Oct 2008
Location: Knoxville, TN
Posts: 110
Default

I'd love to hear the update as to whether this fixes your heel side problem man. I ride 390 boss's as well but never felt like I had any edge problems. Quite frankly I have more control in each foot after switching to these from 09' cartels(the most leaned forward binding I've ever seen). Had never thought of the effect moving the foot bed would have but it definitely makes sense. Looks like pressure was being put too far inside the edge of the board before.

As for the forward lean, dont be discouraged by the ammount of clicks bro. Took me three just to get the highback close to touching the back of my boot. I'd say it'd take five to get to what my cartels sit at with no "clicks". One of the things I love about switching to a true 0 degree lean though is the difference in feel you get under foot when transitioning between edges. I was so used to using mostly legs to get on my heels with the cartels. These took some getting used to but have pleasantly surprised me with a new style of riding. A skater feel is what i'd describe it as.
__________________
Rome Artifact 153/ Burton Deuce 155: Burton Cartel: K2 Raider
lcstriker07 is offline   Reply With Quote
Old 03-07-2013, 08:05 PM   #36 (permalink)
Banned
 
Join Date: Apr 2012
Posts: 1,966
Default

Quote:
Originally Posted by Extremo View Post
You shouldn't have your highbacks in the front holes. They need to be back against the heel loop. You're probably losing all of your heelside leverage because clearly your boot is too far forward in the binding and over the board.
Yes, I noticed that as well.

Cyfer: It looks like you messed up when rotating the highbacks. Not uncommon with Rome, because the rotation is a combination of changing holes on the highback (inner holes) and the baseplate (outer holes). Definitely check the manual sheet on this to get it right.
hktrdr is offline   Reply With Quote
Old 03-07-2013, 10:49 PM   #37 (permalink)
Senior Member
 
Cyfer's Avatar
 
Join Date: Feb 2013
Posts: 118
Default

There's no rotation right now but I see what you're talking about. Planning to fix that sometime today or tomorrow before I ride these again. Hopefully it all works out soon. Not willing to give up yet, but just keeps me thinking Union is the way to go for me. I've never had any issues with either my Contacts or my Forces.
Cyfer is offline   Reply With Quote
Old 03-08-2013, 04:52 PM   #38 (permalink)
Senior Member
 
Cyfer's Avatar
 
Join Date: Feb 2013
Posts: 118
Default

Quote:
Originally Posted by Extremo View Post
You shouldn't have your highbacks in the front holes. They need to be back against the heel loop. You're probably losing all of your heelside leverage because clearly your boot is too far forward in the binding and over the board.
Rotated and pushed the high backs as far as a can into the heel loops without causing the loops to block the high back from folding all the way down. Seems to be a huge help too. Going to ride these this weekend. Thank you everyone, this is my last try with these bindings. It they ride like shit they are going back. All the feedback here has helped a lot. Will post a final pic of the set up very soon.
Cyfer is offline   Reply With Quote
Old 03-10-2013, 10:26 PM   #39 (permalink)
Senior Member
 
Cyfer's Avatar
 
Join Date: Feb 2013
Posts: 118
Default

So I'm happy to say after being out on the hill from 8am to 8pm and using my Skate Banana and my Rome 390 Boss with my Thirty-Two Lashed boots I had a great day out all day. Zero issues, heel side was the strongest it's been ever. Used the 3.5 canted foot beds and they were rock solid all damn day. I want to say thank you to everyone who posted on this thread and helped out setting up these bindings. It took some time and few days out but they felt so natural on the board. Fully happy with them now too. As I was told ended up cutting back my forward lean to two clicks too.

Very nice bindings, I could see myself riding them on either my TRS or my Skate Banana in the future. Again thank you all, all the suggestions really helped figuring this out.
Cyfer is offline   Reply With Quote
Old 03-26-2013, 08:21 PM   #40 (permalink)
Senior Member
 
Cyfer's Avatar
 
Join Date: Feb 2013
Posts: 118
Question

~~~~~~ UPDATE~~~~~~

So after many days of tweaking, posting, riding, tweaking some more and riding again I've finally dialed in these bad boys. I've got these bindings running perfectly now and I do really like them. They ride well with my TRS and the canting with the stiffer board and bindings make this setup handle like a dream. Took a lot of time and I've got to say thanks to everyone who posted here and gave advice on the set up.

Took the TRS out for a ride day on Saturday and had a great day all day. This board is a damn rocket and these bindings make riding it perfect. Great day on Saturday, again thanks everyone I almost gave up on the bindings.

~~~ Final Setup Photo~~~
Attached Images
File Type: jpg image.jpg (120.6 KB, 48 views)
Cyfer is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:18 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
VerticalSports
Baseball Forum Golf Forum Boxing Forum Snowmobile Forum
Basketball Forum Soccer Forum MMA Forum PWC Forum
Football Forum Cricket Forum Wrestling Forum ATV Forum
Hockey Forum Volleyball Forum Paintball Forum Snowboarding Forum
Tennis Forum Rugby Forums Lacrosse Forum Skiing Forums