Snowboarding Forum - Snowboard Enthusiast Forums

Snowboarding Forum - Snowboard Enthusiast Forums (http://www.snowboardingforum.com/forum.php)
-   Bindings (http://www.snowboardingforum.com/bindings/)
-   -   Burton mounting disc (http://www.snowboardingforum.com/bindings/72362-burton-mounting-disc.html)

tonez 03-06-2013 08:43 PM

Burton mounting disc
 
Ok, so i just got my '13 Malavitas in today and when i try to use the 4x4 disc, it won't fully go all the way in to the baseplate no matter how much force i put, the screws won't reach the mounting holes, does anyone else have this problem with theirs?

cav0011 03-06-2013 08:52 PM

the first time i mounted my vita's it felt like that, eventually i got it seated right and with a good amount of pressure applied to the bolt I was able to get it threaded.... never had a repeat of that issue ones I mounted them once though.

crash77 03-06-2013 09:22 PM

This won't be much help to you, but mine arrive Monday. I can let you know if I have any issues.

OU812 03-07-2013 12:29 PM

Not sure if the same mounting disc is used because I have 2012 Cartels, but my problem was the mounting disc holes didn't exactly match up with the boards bushings so I had to widen one a bit on the Burton mounting disc. I have a Lib Tech TRS 2012/13

j1nftw1n 03-08-2013 03:42 AM

Quote:

Originally Posted by cav0011 (Post 811394)
the first time i mounted my vita's it felt like that, eventually i got it seated right and with a good amount of pressure applied to the bolt I was able to get it threaded.... never had a repeat of that issue ones I mounted them once though.



What he said, I got mine yesterday. Apply pressure while you mount and once it threads you'll see the washer bend outwards from the pressure. This was on a Billy goat

604al 03-08-2013 04:35 PM

people usually have this problem with Rome bindings because of their rubber dampening pad... LIGHTLY partially screw down one screw without the washer, then screw down the other 3 with washers, pull out first one, add a washer, and it should be good.

jdang307 03-08-2013 04:57 PM

Never had a problem with Burton or Rome but did with Raiden. I felt like the binding was being held with just one or two threads of the screws.

It got better after uses though.

NWBoarder 03-08-2013 05:53 PM

When I first got my Rome 390 Boss bindings I thought I was gonna have the same problem. Once I used enough pressure to get a screw seated, the rest went in easily. Now, I have no problems with it at all. Everthing fits right on the first try.

tonez 03-10-2013 02:20 PM

problem solved, got a replacement pair and they fit better


All times are GMT -5. The time now is 04:38 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2