Advice on putting Ride bindings back together? - Snowboarding Forum - Snowboard Enthusiast Forums
SnowboardingForum.com is the premier Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-21-2009, 05:15 AM   #1 (permalink)
Senior Member
 
Join Date: Mar 2008
Posts: 123
Default Advice on putting Ride bindings back together?

I'm setting up my Ride CAD bindings for the first time and I nearly got to the point of throwing them out the window... I just opened up a can of worms... I'm dealing with the ankle strap / highback rotation set of screws/washers type thingies? and i CANNOT for the life of me get it back to original factory clearences... The highback screws are nearly impossible to screw back in perfectly and the ankle strap joint? is just freely flopping back and forth instead of pretty tight...

Um.. is this a sign of bad binding design? My Burton's were a cake walk... everything fit together nice and tight, not much sweat... This.. this is trying my patience.

Last edited by SilverK20A3; 03-21-2009 at 05:18 AM.
SilverK20A3 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-21-2009, 05:48 AM   #2 (permalink)
-LIFETIME MEMBER-
 
B.Gilly's Avatar
 
Join Date: Jul 2008
Location: Berkshires
Posts: 774
Default

Have ride bindings myself and the set up is the worst. Part of that being that they are all metal so when you changes the set up there is not a lot of flex in them. So screwing them back in takes a bit. Just takes a bit of patience and a little finagling.

Just make sure the washer pieces are firmly through both pieces your are screwing together is about the best advice I can give on this. It is a pain but I love mine now that they are all dialed in.

Also once I had mine all set up I strapped in my boots for a day or two to get the toe strap to conform a bit to my boot. Not sure if it really helped but it seemed to let the strap conform a bit to my boot.
__________________
The season is almost upon us!!!!


www.facebook.com/Gillyssnowboardshop

Last edited by B.Gilly; 03-21-2009 at 06:04 AM.
B.Gilly is offline   Reply With Quote
Old 03-21-2009, 10:34 PM   #3 (permalink)
Senior Member
 
Join Date: Mar 2008
Posts: 123
Default

Thanks! I finally got everything back together.
SilverK20A3 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:17 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
VerticalSports
Baseball Forum Golf Forum Boxing Forum Snowmobile Forum
Basketball Forum Soccer Forum MMA Forum PWC Forum
Football Forum Cricket Forum Wrestling Forum ATV Forum
Hockey Forum Volleyball Forum Paintball Forum Snowboarding Forum
Tennis Forum Rugby Forums Lacrosse Forum Skiing Forums