Issues with 09 Rome 390s? - Snowboarding Forum - Snowboard Enthusiast Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 04-15-2009, 10:46 AM Thread Starter
Veteran Member
 
Join Date: Feb 2008
Posts: 1,610
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Issues with 09 Rome 390s?

Just curious if anyone has had issues with their 2009 390s. Read elsewhere that the lean adjuster keeps coming loose and that the design (ie the teal or black and white colouring) peels off. Can anyone confirm/dispel or add anything to this.

Thanks!
DC5R is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-15-2009, 11:13 AM
-LIFETIME MEMBER-
 
legallyillegal's Avatar
 
Join Date: Oct 2008
Location: fuck Snowboarding
Posts: 4,492
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It appears that Rome went cheap this year.

THERE ARE SPECIFIC REASONS AS TO WHY I AM MORE LOCAL THAN YOU


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
legallyillegal is offline  
post #3 of 5 (permalink) Old 04-15-2009, 01:16 PM
Member
 
jardo56's Avatar
 
Join Date: Mar 2009
Location: Regina, Sk
Posts: 83
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
You mean every "anti-burton" snowboarder's favourite company in the whole wide world, Rome, is having issues with their gear? Omg the sky is falling!
jardo56 is offline  
post #4 of 5 (permalink) Old 04-15-2009, 01:28 PM
Veteran Member
 
Penguin's Avatar
 
Join Date: May 2008
Location: Burbank, CA
Posts: 904
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My left lean adjustment knob was loose but I just didn't know how to tighten it. Haven't had a problem since I figured out...how to...turn...a knob...

haha


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Penguin is offline  
post #5 of 5 (permalink) Old 04-15-2009, 09:12 PM
Snow-4-Ever
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
Ya, the forward lean used to come loose but it didnt more or anything, it was just like it was done up. Also if you took the time to set it then tight it with an alen wrench it was fine.
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome