Help! Flow Bindings Incompadible with Burton Board? - Page 2 - Snowboarding Forum - Snowboard Enthusiast Forums
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 22 (permalink) Old 12-12-2007, 09:14 AM
Junior Member
 
Join Date: Dec 2007
Location: Ottawa
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Dude, the first one is the universal disc, it will fit pretty much any board! And yes, Burton is only 3 screws.
rick1 is offline  
Sponsored Links
Advertisement
 
post #12 of 22 (permalink) Old 12-12-2007, 09:17 AM
Senior Member
 
Grimdog's Avatar
 
Join Date: Oct 2007
Location: Alberta, Canada
Posts: 780
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The third one is the Burton Specific Disc.
Grimdog is offline  
post #13 of 22 (permalink) Old 12-12-2007, 10:17 AM
Junior Member
 
Join Date: Dec 2007
Location: Ottawa
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Grimdog
The third one is the Burton Specific Disc.
True... but the first one came with my NXTs and I use them on my Atomic and my Burton.. I think the OP just thought his Burton needed 4 bolts. He doesn't have to buy a Burton specific disc..
rick1 is offline  
post #14 of 22 (permalink) Old 12-12-2007, 11:42 AM
Senior Member
 
Grimdog's Avatar
 
Join Date: Oct 2007
Location: Alberta, Canada
Posts: 780
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Oh yeah, sorry. I thought he was saying that he found the other 2 sets of discs with his bindings. Yeah, the discs that came with his Amp 5s are the universal discs. I got the same ones with my NXTs.
Grimdog is offline  
post #15 of 22 (permalink) Old 12-12-2007, 11:49 PM
munchgrunch
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
I used the universal discs and mounted the Flow bindings to my board. Here is a picture I took of how it looks:



Did I mount everything correctly? Is the front binding (normal, not goofy) angled the right amount? Are the screws positioned well?

Sorry for all the questions just the first time I'm mounting bindings on my own!
post #16 of 22 (permalink) Old 12-13-2007, 08:44 AM
Senior Member
 
romesaz's Avatar
 
Join Date: Nov 2007
Location: Toronto, Canada
Posts: 351
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by munchgrunch
I used the universal discs and mounted the Flow bindings to my board. Here is a picture I took of how it looks:



Did I mount everything correctly? Is the front binding (normal, not goofy) angled the right amount? Are the screws positioned well?

Sorry for all the questions just the first time I'm mounting bindings on my own!
I've heard it's good to use the same screw positions (mirror them) so that the tension on the board is equal, but I'm a noob, so I may not know what I'm talking about.

Last edited by romesaz; 12-13-2007 at 11:24 AM.
romesaz is offline  
post #17 of 22 (permalink) Old 12-13-2007, 08:52 AM
Senior Member
 
Grimdog's Avatar
 
Join Date: Oct 2007
Location: Alberta, Canada
Posts: 780
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Sorry noob, but in my book that dude rides regular. Also, I would try and get your front binding screws in more of a triangular pattern.
Grimdog is offline  
post #18 of 22 (permalink) Old 12-13-2007, 09:37 AM
Junior Member
 
Join Date: Dec 2007
Location: Ottawa
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Heheh dude remove your bindings, and look closely at the holes on your board.. you should see a triangle on each side. That's where you want your bolts. So align the holes of the disc on holes located on the three points of the triangle on the board and it should look like this..

rick1 is offline  
post #19 of 22 (permalink) Old 12-13-2007, 09:52 AM
Veteran Member
 
killclimbz's Avatar
 
Join Date: Aug 2007
Location: Front Range
Posts: 11,165
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 46 Post(s)
rick, thanks for straightening that one out. I really don't ride Burton product so I didn't know they already had it accounted for. I guess I could have looked at my flows and figured this out...
killclimbz is offline  
post #20 of 22 (permalink) Old 12-13-2007, 11:25 AM
Senior Member
 
romesaz's Avatar
 
Join Date: Nov 2007
Location: Toronto, Canada
Posts: 351
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Grimdog
Sorry noob, but in my book that dude rides regular. Also, I would try and get your front binding screws in more of a triangular pattern.

hahah, dumb mistake! I have no idea what's going on, but I seem to mistaking directions lately
romesaz is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome