Skate banana quality? - Snowboarding Forum - Snowboard Enthusiast Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 02-13-2011, 07:55 PM Thread Starter
Junior Member
 
Join Date: Jan 2010
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Skate banana quality?

Just wondering if anyone has had this problem with there 09/10 Skate Banana. It seems to be just on the red area of the base. where it blends into yellow, only the red is pitted, and the yellow is fine. it is worn so much that the inside area of the edge is now higher and digs into the snow when i ride. i only have 15 days on the board. I have never seen this before on any other board that i have owned. let me know what you think.
2011-02-08_18-04-29_150.jpg

2011-02-08_18-05-20_978.jpg

2011-02-10_18-00-16_427.jpg

2011-02-10_18-00-34_872.jpg
Erban32 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 02-13-2011, 08:22 PM
Veteran Member
 
Lstarrasl's Avatar
 
Join Date: Mar 2010
Location: Carlsbad
Posts: 647
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
just get a tune up with base grind. Then you will be happy again.
Lstarrasl is offline  
post #3 of 7 (permalink) Old 02-13-2011, 08:29 PM
Junior Member
 
Flat4Wagon's Avatar
 
Join Date: Jan 2011
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Nothing a nice hotwax can't fix. If your Skate Banana is like mine you have to wax it every 3-4 times out anyway.

Lib Attack Banana 159
Lib Skate Banana 159
Burton Bullet 159w
Union Force bindings
Burton Grail boots
Flat4Wagon is offline  
post #4 of 7 (permalink) Old 02-13-2011, 08:48 PM
Veteran Member
 
slyder's Avatar
 
Join Date: Jan 2010
Location: Milwaukee Suburbs
Posts: 3,521
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Flat4Wagon View Post
Nothing a nice hotwax can't fix. If your Skate Banana is like mine you have to wax it every 3-4 times out anyway.
I agree with this and mine is a black base with no issues like that call Mervin Ph: 360-683-9414

-I'm Slyder and I suffer from "Gummer Syndrome"

Last edited by slyder; 02-13-2011 at 08:52 PM.
slyder is offline  
post #5 of 7 (permalink) Old 02-13-2011, 09:01 PM Thread Starter
Junior Member
 
Join Date: Jan 2010
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The pictures were taken right after I waxed the board. it was waxed almost every 3-4 times out. I brought it to a shop to have to tuned and they said they would have to fill the entire side with p-tec and then grind it back down. The also recommended looking into why it is wearing so fast. It is just strange that it is only on the red areas of the base. the yellow is fine, and where it transitions from red to yellow, only the red has little holes/pits in it. I have contacted Lib tech and I am waiting to see what they say.
Erban32 is offline  
post #6 of 7 (permalink) Old 02-14-2011, 02:21 AM
Member
 
init's Avatar
 
Join Date: Mar 2010
Location: Kristiansand, Norway
Posts: 82
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
None of my previous boards have had that problem. I would've called Lib
init is offline  
post #7 of 7 (permalink) Old 02-14-2011, 08:23 AM
Senior Member
 
mbesp's Avatar
 
Join Date: Jan 2009
Location: Minnesota
Posts: 354
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I've never seen that before on any boards. doesn't look good to me haha.
mbesp is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome