Rome 390 problem - Snowboarding Forum - Snowboard Enthusiast Forums
SnowboardingForum.com is the premier Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-07-2008, 06:02 PM   #1 (permalink)
Trace63
Guest
 
Posts: n/a
Default Rome 390 problem

Hey, first off here are some pics of my pimpin new gear. Question is though, when I try to screw in the bindings to the board the threads won't catch with the washers on. (second to last pic) But when the washer is taken off, they catch and screw in. What should I do?







Also, I never knew that boards come with this kind of cut. Its on an angle and comes to a sharp point on the base.



  Reply With Quote
Sponsored Links
Advertisement
 
Old 03-07-2008, 06:07 PM   #2 (permalink)
andrew_schenk
Guest
 
Posts: n/a
Default

how far do the screws stick out the bottom of the binding?

you can always just go to a hardware store and get some long flat head phillips screws.. ill grab my thread pitch gage and find out the thread pitch and edit this post.

edit: the thread is an M10 X 1.0... and yes that means metric.

also, there is the rubber pad (atleast on my targas there is) that goes between the bindings and the board, make sure that is seated properly and you may have to push on the screw a bit to squeeze the rubber down.

Last edited by andrew_schenk; 03-07-2008 at 06:15 PM.
  Reply With Quote
Old 03-07-2008, 06:08 PM   #3 (permalink)
BeeDee
Guest
 
Posts: n/a
Default

I think i had the same problem when i set my board up with the targas. If you push down on the whole binding (or the base of the binding rather) it seems to catch.
  Reply With Quote
Old 03-07-2008, 06:33 PM   #4 (permalink)
Trace63
Guest
 
Posts: n/a
Default

Woohoo! All screwed in. It just sucks that this weather is being a biznatch and a half this weekend.
  Reply With Quote
Old 03-07-2008, 06:37 PM   #5 (permalink)
BoardTard Xtrordinair
 
Mr. Right's Avatar
 
Join Date: Sep 2007
Location: Colorado
Posts: 1,476
Default

Good to see you got it together NICE equipment man
__________________
When the fuck did we get ice cream?
Mr. Right is offline   Reply With Quote
Old 03-07-2008, 06:38 PM   #6 (permalink)
andrew_schenk
Guest
 
Posts: n/a
Default

that sucks man, im in south-eastern ontario and getting hit with 30-40cm (12-15in.) of snow by sunday... gunna be some nice riding
  Reply With Quote
Old 03-07-2008, 07:16 PM   #7 (permalink)
Trace63
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by andrew_schenk View Post
that sucks man, im in south-eastern ontario and getting hit with 30-40cm (12-15in.) of snow by sunday... gunna be some nice riding
God hates you FYI
  Reply With Quote
Old 03-08-2008, 06:21 AM   #8 (permalink)
xevi89
Guest
 
Posts: n/a
Default

1) Congrats on getting the (kickass) bindings on

2)What board is that?

3)Ohio is getting DUMPED on, it has been snowing nonstop since yesterday at 9AM
  Reply With Quote
Old 03-08-2008, 06:48 AM   #9 (permalink)
-LIFETIME MEMBER-
 
kri$han's Avatar
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 1,486
Default

Quote:
Originally Posted by Snowolf View Post
Rome gear rocks! I love my 390`s..

For anyone who has this problem, the fix is to screw in 2 of the screws without washers to compact the rubber vibration dampenr under the binding, then screw in the two with the washer. Unscrew the original washer-less screws and re install with their washers.
yeap. this is the proper way.. do NOT, ever use any screws that aren't meant to be binding screws, like someone suggested...

binding screws have a special loctite on them (loctite Blue, if anyone cares, most people don't have this at home, its like $15 for a 10ml bottle), and they can't be too long, or they might push out the bottom.
__________________
Official 'Eh' Team representative

Kris
Toronto Prelude Club
kri$han is offline   Reply With Quote
Old 03-08-2008, 01:28 PM   #10 (permalink)
Trace63
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by xevi89 View Post
1) Congrats on getting the (kickass) bindings on

2)What board is that?

3)Ohio is getting DUMPED on, it has been snowing nonstop since yesterday at 9AM
Rome 168cm Flag
  Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:04 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
VerticalSports
Baseball Forum Golf Forum Boxing Forum Snowmobile Forum
Basketball Forum Soccer Forum MMA Forum PWC Forum
Football Forum Cricket Forum Wrestling Forum ATV Forum
Hockey Forum Volleyball Forum Paintball Forum Snowboarding Forum
Tennis Forum Rugby Forums Lacrosse Forum Skiing Forums