Rome 390 problem - Snowboarding Forum - Snowboard Enthusiast Forums
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 03-07-2008, 06:02 PM
Trace63
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
Rome 390 problem

Hey, first off here are some pics of my pimpin new gear. Question is though, when I try to screw in the bindings to the board the threads won't catch with the washers on. (second to last pic) But when the washer is taken off, they catch and screw in. What should I do?







Also, I never knew that boards come with this kind of cut. Its on an angle and comes to a sharp point on the base.



Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 03-07-2008, 06:07 PM
andrew_schenk
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
how far do the screws stick out the bottom of the binding?

you can always just go to a hardware store and get some long flat head phillips screws.. ill grab my thread pitch gage and find out the thread pitch and edit this post.

edit: the thread is an M10 X 1.0... and yes that means metric.

also, there is the rubber pad (atleast on my targas there is) that goes between the bindings and the board, make sure that is seated properly and you may have to push on the screw a bit to squeeze the rubber down.

Last edited by andrew_schenk; 03-07-2008 at 06:15 PM.
post #3 of 12 (permalink) Old 03-07-2008, 06:08 PM
BeeDee
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
I think i had the same problem when i set my board up with the targas. If you push down on the whole binding (or the base of the binding rather) it seems to catch.
post #4 of 12 (permalink) Old 03-07-2008, 06:33 PM
Trace63
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
Woohoo! All screwed in. It just sucks that this weather is being a biznatch and a half this weekend.
post #5 of 12 (permalink) Old 03-07-2008, 06:37 PM
BoardTard Xtrordinair
 
Mr. Right's Avatar
 
Join Date: Sep 2007
Location: Colorado
Posts: 1,476
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Good to see you got it together NICE equipment man

When the fuck did we get ice cream?
Mr. Right is offline  
post #6 of 12 (permalink) Old 03-07-2008, 06:38 PM
andrew_schenk
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
that sucks man, im in south-eastern ontario and getting hit with 30-40cm (12-15in.) of snow by sunday... gunna be some nice riding
post #7 of 12 (permalink) Old 03-07-2008, 07:16 PM
Trace63
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
Quote:
Originally Posted by andrew_schenk View Post
that sucks man, im in south-eastern ontario and getting hit with 30-40cm (12-15in.) of snow by sunday... gunna be some nice riding
God hates you FYI
post #8 of 12 (permalink) Old 03-08-2008, 06:21 AM
xevi89
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
1) Congrats on getting the (kickass) bindings on

2)What board is that?

3)Ohio is getting DUMPED on, it has been snowing nonstop since yesterday at 9AM
post #9 of 12 (permalink) Old 03-08-2008, 06:48 AM
-LIFETIME MEMBER-
 
kri$han's Avatar
 
Join Date: Feb 2007
Location: Toronto, Ontario
Posts: 1,492
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Quote:
Originally Posted by Snowolf View Post
Rome gear rocks! I love my 390`s..

For anyone who has this problem, the fix is to screw in 2 of the screws without washers to compact the rubber vibration dampenr under the binding, then screw in the two with the washer. Unscrew the original washer-less screws and re install with their washers.
yeap. this is the proper way.. do NOT, ever use any screws that aren't meant to be binding screws, like someone suggested...

binding screws have a special loctite on them (loctite Blue, if anyone cares, most people don't have this at home, its like $15 for a 10ml bottle), and they can't be too long, or they might push out the bottom.

Official 'Eh' Team representative

Kris

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
kri$han is offline  
post #10 of 12 (permalink) Old 03-08-2008, 01:28 PM
Trace63
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
Quote:
Originally Posted by xevi89 View Post
1) Congrats on getting the (kickass) bindings on

2)What board is that?

3)Ohio is getting DUMPED on, it has been snowing nonstop since yesterday at 9AM
Rome 168cm Flag
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome