My board is chipping - Snowboarding Forum - Snowboard Enthusiast Forums
User Tag List

LinkBack Thread Tools
Display Modes
post #1 of 2 (permalink) Old 03-09-2008, 08:12 PM
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
My board is chipping

Hi guys, have had my 06 Salomon Pulse for about 2 months now (gone out 7 days or so), and I have a pretty big chip on the front right side of the board. As far as I can tell, the chip doesn't go to the wood core, just the canvas above that. How can I fix this? Or at least stop more of the surface from coming off? Thanks.
Sponsored Links
post #2 of 2 (permalink) Old 03-10-2008, 12:55 AM
Senior Member
Join Date: Jan 2008
Posts: 232
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Sand/file the chip smooth, then apply epoxy. Wait for it to dry, then sand/file it smooth again. Simple fix.
scottland is offline  

Quick Reply

Register Now

In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome