Foot Pain - Page 7 - Snowboarding Forum - Snowboard Enthusiast Forums
User Tag List

LinkBack Thread Tools
Display Modes
post #61 of 62 (permalink) Old 03-11-2013, 07:40 AM
Senior Member
behi's Avatar
Join Date: Feb 2013
Posts: 142
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Originally Posted by jtg View Post
Yeah, I've experimented a lot with tightening. It seems to help somewhat if they are that loose, but then your heel comes halfway out on toe-side turns, and riding is pretty much impossible.
For me, if I only keep the lower section loose, there is no significant difference in heel hold (the upper section is really tight). What makes a big difference in ankle hold/heel lift is the ankle strap angle. The strap mounting holes that are the furthest back/highest work by far the best for me.

Also, a binding with a capstrap is a lot more comfortable for my forefoot (in case, you don't have one).

Last edited by behi; 03-11-2013 at 07:50 AM.
behi is offline  
Sponsored Links
post #62 of 62 (permalink) Old 01-15-2014, 06:41 AM
Junior Member
Join Date: Jan 2014
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

I know this is an old thread but I had this issue could not go down a slope without painful cramps in ball of feet and had to stop ever minute or so .. Green slopes were unbarable etc nightmare... Pain was bad with both Flows and Burton P1 bindings, Previous boots i had were Burton and some other makes (cant remember) all gave me pain.
My solution was a pair of Quenchu Snowboard boots... I dont know what model they were but they were very cheap about 20 at the time... and the only thing I can think why the pain stopped was because they are wide and even if i try and tighten the straps on bindings down on these boots compared to other boots I have had they seem like they can cope with the pressure of the straps (a bit like steel toe capped boots for snowboarders lol ).. When i get home i will try and find out the model of boots I have...and post...
But good luck as until i found these boots i wrecked 2 holidays.... :
richm6 is offline  

Quick Reply

Register Now

In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome