What is causing this? - Page 2 - Snowboarding Forum - Snowboard Enthusiast Forums
SnowboardingForum.com is the premier Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-16-2013, 11:20 PM   #11 (permalink)
-LIFETIME MEMBER-
 
ARSENALFAN's Avatar
 
Join Date: Apr 2012
Location: Calgary
Posts: 910
Default

Quote:
Originally Posted by smerdyakov View Post
That damage is crazy, but I'm a bit confused: Are those boots the 2011-12 UFOs?

BA- Is that damage common for K2 boots? It looks like this year's version may have a different material in that area?

I apologize if I hijacked the thread. Just wondering before I invest in some T1 boots.
They are this years boots - brand new.
ARSENALFAN is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:34 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
VerticalSports
Baseball Forum Golf Forum Boxing Forum Snowmobile Forum
Basketball Forum Soccer Forum MMA Forum PWC Forum
Football Forum Cricket Forum Wrestling Forum ATV Forum
Hockey Forum Volleyball Forum Paintball Forum Snowboarding Forum
Tennis Forum Rugby Forums Lacrosse Forum Skiing Forums