How fixable are Burton Speed Laces? - Snowboarding Forum - Snowboard Enthusiast Forums
SnowboardingForum.com is the premier Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-23-2013, 01:20 AM   #1 (permalink)
Junior Member
 
Join Date: Feb 2013
Posts: 26
Default How fixable are Burton Speed Laces?

Just had the bottom lace on one of my 2012 Burton Ions go out today. It's not a snapped lace, it's like the system broke and the lace just won't pull at all anymore. I've tried to figure it out, but I'm also trying not to break things further with my investigations...

Total bummer end of day too - it was an absolute pain to even get my foot our of the boot since I couldn't loosen the dang thing.

Anyway, is this the end? Is this something common? These were great boots, but a season and a half seems pretty light for $300+
Conrad Hart is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-23-2013, 06:10 AM   #2 (permalink)
Senior Member
 
PalmerFreak's Avatar
 
Join Date: Jul 2009
Posts: 313
Default

I had a pair of SL-8's and currently have a pair of SL-10's with the speed lace system and have never had an issue with either of them so i would consider your situation atypical.

I did find some references for replacing a broken speed lace - this one has step-by-step instructions:

oneballjay: How to lace the Burton Speed lace boots in 10 min.

From what I've been able to gather, if you order the new lace from Burton they will send you a tool that helps in the repair but I guess you'd need to contact rider services to double check.

Good luck man.
PalmerFreak is online now   Reply With Quote
Old 03-23-2013, 07:59 AM   #3 (permalink)
Veteran Member
 
Join Date: Sep 2011
Posts: 1,377
Blog Entries: 9
Default

Quote:
Originally Posted by Conrad Hart View Post
Just had the bottom lace on one of my 2012 Burton Ions go out today. It's not a snapped lace, it's like the system broke and the lace just won't pull at all anymore. I've tried to figure it out, but I'm also trying not to break things further with my investigations...

Total bummer end of day too - it was an absolute pain to even get my foot our of the boot since I couldn't loosen the dang thing.

Anyway, is this the end? Is this something common? These were great boots, but a season and a half seems pretty light for $300+
Something is jammed, it's totally fixable.
Lamps is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:26 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
VerticalSports
Baseball Forum Golf Forum Boxing Forum Snowmobile Forum
Basketball Forum Soccer Forum MMA Forum PWC Forum
Football Forum Cricket Forum Wrestling Forum ATV Forum
Hockey Forum Volleyball Forum Paintball Forum Snowboarding Forum
Tennis Forum Rugby Forums Lacrosse Forum Skiing Forums