Snowboarding Forum - Snowboard Enthusiast Forums

Snowboarding Forum - Snowboard Enthusiast Forums (http://www.snowboardingforum.com/forum.php)
-   General Equipment Reviews. (http://www.snowboardingforum.com/general-equipment-reviews/)
-   -   Toko T14 Iron - Technical question. (http://www.snowboardingforum.com/general-equipment-reviews/118833-toko-t14-iron-technical-question.html)

Sam_g 01-11-2014 08:00 PM

Toko T14 Iron - HELP - Technical question.
 
Hello to all,

This is my first topic :D, i'm new and I hope the forum category for this topic is fine.
I bought a Toko T14 Iron, and I saw a strange behavior. I tried the followings:
1. I plugged in the Iron (by default is 130'C)
2. I set the temp to 150'C
3. Green led is OFF, I saw on the display the current temp, it's increasing, everything is fine, When temp is equal to 150, the green led is ON.
4. I set the temp. to 90'C, and this is the strange thing, the green led remains on, and on the display remains 90'C. This behavior is very strange for me, I expected on the display the current temp.

Can someone help me?

Hope that my writing is right. And you will understand my concern. Thanks

readimag 01-11-2014 08:50 PM

Send it back and get a new one it should not be doing that.

Sam_g 01-12-2014 03:23 AM

Quote:

Originally Posted by readimag (Post 1426281)
Send it back and get a new one it should not be doing that.

Do you have a Toko, and you have a different behavior if you decrese the temp? Which should be the behavior if you are going from 150'C to 90'C?

Thank you

speedjason 01-12-2014 10:58 PM

I guess the code does not automatically update current temp when its higher than set temp.
dude you cashed out some good money for that digital wax iron.

Sam_g 01-13-2014 01:01 AM

Quote:

Originally Posted by speedjason (Post 1429569)
I guess the code does not automatically update current temp when its higher than set temp.
dude you cashed out some good money for that digital wax iron.

This is what I also quess, but I'm not sure, I want to know for sure if this is the behavior of the TOKO, or should I send it back to the shop...

havin_a_ball 01-13-2014 06:54 AM

Sounds like you should send it back.

http://i.ebayimg.com/t/Toko-Wax-Iron...T2!~~60_35.JPG

I have a Toko just like this. There's not really any way to break it to where you couldn't fix it yourself. Metal & a cord. I like the space for wax inside it which drops out 2 eyeholes when squeezed. It doens't burn the wax and by turning the dial, you know relatively how hot it is, just like a stove.

If you keep having trouble, maybe consider one of these. At the very least, it's fun to use, sturdy, and cheap, not practical for air travel though.

DevilWithin 01-13-2014 07:22 AM

I only have the cheap toko wax iron, so I have no idea how that beast is supposed to work. Where did you buy it? If you got it from a place like Tognar, you should just email / call them to find out if it is working properly. I'd venture to guess that Speedjason and you are correct in assuming that the code doesn't reset once it reaches the higher temp and is set to a lower temp.

Sam_g 01-13-2014 07:40 AM

Quote:

Originally Posted by havin_a_ball (Post 1429921)
Sounds like you should send it back.

http://i.ebayimg.com/t/Toko-Wax-Iron...T2!~~60_35.JPG

I have a Toko just like this. There's not really any way to break it to where you couldn't fix it yourself. Metal & a cord. I like the space for wax inside it which drops out 2 eyeholes when squeezed. It doens't burn the wax and by turning the dial, you know relatively how hot it is, just like a stove.

If you keep having trouble, maybe consider one of these. At the very least, it's fun to use, sturdy, and cheap, not practical for air travel though.



I really need a support from someone who has a Toko T14. But anyway, thank you :D

Sam_g 01-13-2014 07:48 AM

Quote:

Originally Posted by DevilWithin (Post 1429945)
I only have the cheap toko wax iron, so I have no idea how that beast is supposed to work. Where did you buy it? If you got it from a place like Tognar, you should just email / call them to find out if it is working properly. I'd venture to guess that Speedjason and you are correct in assuming that the code doesn't reset once it reaches the higher temp and is set to a lower temp.

I bought the iron from a very small shop, this is the reason why I asked you guys.. I have to know for sure if my iron is broken, or this is the real behavior...

DevilWithin 01-13-2014 07:52 AM

You'll get a more accurate and better response if you posted this question to the Toko social media sites. I'm assuming you are in the US, so here are links to FB and Twitter. If you're not US, you should do a quick google search to find the appropriate social media channel for your country / region.
Facebook: https://www.facebook.com/pages/Toko-US/156305081080636
Twitter: https://twitter.com/TokoUS

To be honest, I don't think many forum members spent that kind of money on a digital wax iron when the cheaper ones work perfectly. Best bet is to ask Toko directly or the store where you bought it.


All times are GMT -5. The time now is 07:01 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2