Snowboarding Forum - Snowboard Enthusiast Forums - Reply to Topic
Thread: Just got my first Splitboard !! Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 
   

Register Now



In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
01-03-2014 08:48 PM
ridinbend Got to fondle a landlord split today,which also came with the voile colab pucks. So sexy!
01-03-2014 08:06 PM
killclimbz I think it is just inherent to the design. I definitely noticed that one side was a little off. But I bet when I split the skis and swap sides both brackets are right where you want 'em.

They are a solid ride for sure. I just moved the interface over to my new Prospector. Taking her out tomorrow. Powder day is on tap.
01-03-2014 07:41 PM
wrathfuldeity Thanks, now not worried about it...just being anal...it didn't make sense...to have the bindings being spec'd tight...but the brackets seemingly being abit off. Sparks noted that there is not right/left touring bracket. Btw had the goat for the first time, just riding our only pow day of 10"...no tour...Afterburners are beastly solid on the pucks.
01-03-2014 07:04 PM
killclimbz Wrath, following back up with ya. My brackets do the same thing. It is just how they sit for attaching your bindings. Unless it does something really wonky I think you are totally fine.
01-02-2014 07:15 AM
killclimbz
Quote:
Originally Posted by Ale_Capone View Post
And if that dont work , try the stranger or cold hand-hot hand.
Always have to try the Stranger. Haven't done the cold hand-hot hand. Solid advice right there!
01-01-2014 03:01 PM
Ale_Capone
Quote:
Originally Posted by killclimbz View Post
I am finding that the mid shaft grab works most of the time. I also figured out a way to lever it grip side if necessary. It's just getting used to the new way of doing it is all. None of the problems I am having are anything close to a show stopper. They may qualify as a minor annoyance.
And if that dont work , try the stranger or cold hand-hot hand.
01-01-2014 10:26 AM
walove 2mm is not much to worry unless they interfere when in ride mode (seen this on a diy board)
12-31-2013 10:10 PM
wrathfuldeity
Quote:
Originally Posted by killclimbz View Post
Weird. They are the same as far as I know. Is your split a DIY or factory?
factory billygoat 159...maybe the inserts are off?...I'll check tomorrow
12-31-2013 09:46 PM
killclimbz Weird. They are the same as far as I know. Is your split a DIY or factory?
12-31-2013 08:20 PM
wrathfuldeity Doing the set up on the Afterburners...quick ? are there a right and left side touring brackets? Both brackets are exactly the same and fit better on the left side (tour mode are centered)...and on the right side, the binding in tour mode is off center to the right by about 2mm.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome