Snowboarding Forum - Snowboard Enthusiast Forums - Reply to Topic
Thread: My New Focus Hylites Broke Today Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 
   

Register Now



In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
02-02-2014 09:58 AM
larrytbull
Fixed !!! :yahoo:




After looking at video and PDF, I determined that the cable had not snapped, it just came loose from the spool on one end. I popped open the spool, and straightened the wire end enough to put it back in the track, a few @#@$@@# later and boot is fixed
Shame on BOA Tech for such a POOR FASTENING SYSTEM
02-01-2014 08:51 PM
larrytbull Thanks guys. I found the guide on Vmeo. And PDF under focus system at boatechnology.com it is an h3 dial with focus system. Hoping laces arrive before weekend. Otherwise back to my motos
02-01-2014 08:48 PM
a4h Saint
Quote:
Originally Posted by larrytbull View Post
How do you replace the wire? is there any website with instructions?
You can do what the others say, or if you live in a small town like me then yes the BOA website has instructions and they will get you replacement parts fairly quick. It really is a very simple swap. There may even be more in-depth guides on here somewhere
02-01-2014 06:10 PM
Donutz
Quote:
Originally Posted by larrytbull View Post
How do you replace the wire? is there any website with instructions?
It's not really hard. Frustrating in the same way that threading a needle is frustrating. Have good swear words lined up.

I replaced the cable on my Ride Jackson Boas a couple of years back. Really no biggie. I think there was a diagram in the package that the cable came in.
02-01-2014 06:07 PM
Argo If you take them to the closest boa certified retailer, they fix them for free.
02-01-2014 05:07 PM
larrytbull
Quote:
Originally Posted by Alkasquawlik View Post
Ya they will warranty it for you. You can also try going to a shop near you that sells product that has the BOA wheel on it, and see if they have spare parts. We had a bunch of replacement BOA parts that we just gave to people if they came in, but not all stores have BOA parts.

FWIW, this is the EXACT reason why I personally will never buy BOA boots, and why I steer customers away from BOA.
How do you replace the wire? is there any website with instructions?
02-01-2014 04:57 PM
Alkasquawlik Ya they will warranty it for you. You can also try going to a shop near you that sells product that has the BOA wheel on it, and see if they have spare parts. We had a bunch of replacement BOA parts that we just gave to people if they came in, but not all stores have BOA parts.

FWIW, this is the EXACT reason why I personally will never buy BOA boots, and why I steer customers away from BOA.
02-01-2014 04:51 PM
larrytbull
My New Focus Hylites Broke Today

Just venting

My new Flow Focus Hylites, Just Broke. They are less than 2 months old.


The Side Boa cables snapped





Can these be repaired?


I put in warranty request to flow website. I tried calling but they are closed on saturday.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome