Snowboarding Forum - Snowboard Enthusiast Forums - Reply to Topic
Thread: old board rusting after a day's riding Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 
   

Register Now



In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
02-05-2014 12:40 AM
Varza
Quote:
Originally Posted by Eat Sleep Shred View Post
Superficial rust for sure, take it out on a run, it'll be gone in like 5 seconds.
My edges get little rust spots too, but I've never worried about it. They look more like stains and never seem to actually be eating the metal to any significant extent.
02-05-2014 12:09 AM
Eat Sleep Shred Superficial rust for sure, take it out on a run, it'll be gone in like 5 seconds.
02-04-2014 10:22 PM
ThisIsSnow
old board rusting after a day's riding

so i took my old rock/park board out for a day on Sunday, and when I came back i briefly wiped it and left it out to dry.

I just realised that there is a coat of rust on the edges - not spots of rust here and there, but both edges look more brown than silver. I'd just tuned that board right before the weekend too, so the rust definitely accumulated over one day's worth of riding.

I don't think edges are supposed to rust that easily, but am I wrong? I'm not sure what's happening - the board is sitting in my room and it isn't particularly humid or anything now. Does the age of the board (i think it's a 2008-09 model) have anything to do with it?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome