Snowboarding Forum - Snowboard Enthusiast Forums - Reply to Topic
Thread: Binding/Boot problem Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 
   

Register Now



In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
02-12-2014 05:27 PM
tserich
Binding/Boot problem

I have 2013 Union Forces and 2012 Rome Libertines. When I tighten my toe strap it cuts off circulation to my left foot. If I loosen it one notch, the toe strap slips off when I start to ride.

My question is whether its mainly the fault of the boots or the bindings? Also should i just get new boots and/or bindings? Or can I do something to alleviate this issue?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome