Snowboarding Forum - Snowboard Enthusiast Forums - Reply to Topic
Thread: burton bindings not working with ride boots Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
02-28-2014 02:27 AM
hayden14 done all the adjustments I can it seems probably just going to take them to a shop and have em check it out or maybe walk away with new gear :/
02-27-2014 08:10 AM
ttccnn You can not adjust the heel cup on burton cartel, but you can try to adjust the position of the ankle straps, hope this helpful
02-27-2014 07:04 AM
SkullAndXbones i see what you mean now. i dont know how customizable the cartel bindings are but is there a way to adjust the heel of the binding? like pulling it back farther? i understand you're frustration. i bought all new stuff last year and the thirtytwo boots i bought wouldn't fit in my targa bindings (which i bought online) so i ended up returning the boots because it was easier to just bring them back to the store and then bought rome boots. you may have to end up returning either the boots or the bindings. like i said earlier, some boot/binding combinations just don't work. i could be wrong but i think this stuff happens when you start mixing and matching brands that all make their own boards, bindings, and boots so that you'll buy all 3 from the same manufacturer. which is why the next time i buy bindings im going with a universal brand like Union or Flux.
02-27-2014 03:22 AM
In burton bindings^

In Ride bindings^

Its hard to tell in the picture but its really difficult to bend the burton bindings over to get them into the ratchet. Once in and tighten down they dont wrap the boot correctly. They put pressure on the outside of the boot and leave a gap in the middle of the boot shown on the picture.

With the rides it wraps around the boot and leaves no gap and even pressure from the strap all around.

I dont know if this means i need new bindings, or an adjustment, or what. Just sucks I bought this stuff assuming it would all be perfect.
02-27-2014 03:13 AM
SkullAndXbones not really sure then. never used cartel bindings or ride boots. some boot and binding combinations can be weird though. thirtytwo and vans boots and i think DC boots won't fit into my rome targa bindings. the boots are too wide. i gotta wear rome boots for them.
02-27-2014 02:38 AM
Originally Posted by SkullAndXbones View Post
did you try adjusting the strap to a longer length?
yeah tried adjusting the length and the strap position. I can get them to fit a little better when the strap is longer but unfortunately then the strap isnt centered.
02-27-2014 02:35 AM
SkullAndXbones did you try adjusting the strap to a longer length?
02-27-2014 02:13 AM
burton bindings not working with ride boots

Ordered a full setup after reviews and trying some stuff on. Got a pair of ride lasso boots and burton cartel bindings. The toe straps are a little ehh on the boots but not too bad. But the ankle strap doesnt fit right at all, it wont flex around the boot no matter what. I have size 9 boots and got Medium bindings.

anyone seen this problem before with burton gear not cooperating with other gear?

I tossed the boots in an old pair of ride bindings and they fit perfect.

I just dont know if theres something im doing wrong or what so just trying to get any feedback,



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome