Snowboarding Forum - Snowboard Enthusiast Forums - Reply to Topic
Thread: Need 2004 Burton P1HD ankle slider strap Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 
   

Register Now



In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
10-11-2011 05:01 PM
glm pretty sure I have the same type ankle strap on my 2011 customs...
10-11-2011 04:55 PM
chrismjx
Need 2004 Burton P1HD ankle slider strap

I broke my ankle slider strap last season, and I've spent all summer trying to locate a replacement. I have tried getting creative, replacing the ankle slider strap with a toe slider strap, but that doesn't work so well and tends to want to slip out of the buckle.

I need one that looks like this half-moon shape on the end; I attached a picture.

I have emailed Burton Rider Services both in the U.S. and in Europe, as well as shops in 3 states and searched all over the internet with no luck. If I can't get this fixed, I might have to sit out the whole season!

Hope someone can help.....

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome