Snowboarding Forum - Snowboard Enthusiast Forums - Reply to Topic
Thread: New bindings advice pls Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
09-12-2012 05:30 PM
RightCoastShred look at some of the middle of the line bindings($100-$200) since your new. Some good brands are burton, rome, ride, union, raiden, and k2. and a medium binding should fit up to a US 9 so do the conversion to uk because i dont know uk sizes
09-12-2012 05:22 PM
New bindings advice pls

Hi, I would really appreciate some advice on new bindings. I'm new to boarding, just over a year, went out twice last season and had a blast, so pretty novice I guess.

Got given an old Santa Cruz traditional camber board which I use, hardly been used despite being old but the bindings are shocking.

My boots are a UK size 8, 32 Prion FT and I do all mountain/groomers when I board at the moment.

So much choice its hard to know which way to turn, also I'm guessing a medium binding will be fine for my boot size?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome