Snowboarding Forum - Snowboard Enthusiast Forums - Reply to Topic
Thread: Is this weird wax residue on my board normal? (picture) Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 
   

Register Now



In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
11-16-2012 07:29 PM
kingneptune117
Is this weird wax residue on my board normal? (picture)

Hey all,

Long story short about months ago I got my board waxed. About 2 months after that I looked at my board (it had been stored in a snowboard bag for those two months) and it had this weird white residue on it. It feels no different then the rest of the board, its just you can definitely see it on the board (the weird white streaks and white marks. Most of my board is flat black but now this weird residue makes some of it look white.)

Again, I cannot feel it at all. It feels completely normal and everything, but it just looks weird and im scared this is not normal. Anyone seen this before?


Almost the entire board normally is black except for the words and designs. Any white blobs/streaks is what im talking about. As you can probably see, I used my nail to try and scrape some of it off. I really dont knows whats going on, but my board should look better then this.

Thanks!

UPDATE*** I just tried taking a brush to it...most of the white stuff came off. I got this board waxed around 6 months ago. Haven't ridden it yet since then, but I will be in about a month. Do I need to take it in for a wax again despite not having ridden on it?

Thanks!


Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome