Snowboarding Forum - Snowboard Enthusiast Forums - Reply to Topic is the premier Forum on the internet. Registered Users do not see the above ads.
Thread: Burton mounting disc Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please pick your gender.
Please select your insurance company (Optional)
What is the highest level of education you have?
What is your own yearly income?
What is your total household income?
including all earners in your household.
What is your current marital status?


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-10-2013 02:20 PM
tonez problem solved, got a replacement pair and they fit better
03-08-2013 05:53 PM
NWBoarder When I first got my Rome 390 Boss bindings I thought I was gonna have the same problem. Once I used enough pressure to get a screw seated, the rest went in easily. Now, I have no problems with it at all. Everthing fits right on the first try.
03-08-2013 04:57 PM
jdang307 Never had a problem with Burton or Rome but did with Raiden. I felt like the binding was being held with just one or two threads of the screws.

It got better after uses though.
03-08-2013 04:35 PM
604al people usually have this problem with Rome bindings because of their rubber dampening pad... LIGHTLY partially screw down one screw without the washer, then screw down the other 3 with washers, pull out first one, add a washer, and it should be good.
03-08-2013 03:42 AM
Originally Posted by cav0011 View Post
the first time i mounted my vita's it felt like that, eventually i got it seated right and with a good amount of pressure applied to the bolt I was able to get it threaded.... never had a repeat of that issue ones I mounted them once though.

What he said, I got mine yesterday. Apply pressure while you mount and once it threads you'll see the washer bend outwards from the pressure. This was on a Billy goat
03-07-2013 12:29 PM
OU812 Not sure if the same mounting disc is used because I have 2012 Cartels, but my problem was the mounting disc holes didn't exactly match up with the boards bushings so I had to widen one a bit on the Burton mounting disc. I have a Lib Tech TRS 2012/13
03-06-2013 09:22 PM
crash77 This won't be much help to you, but mine arrive Monday. I can let you know if I have any issues.
03-06-2013 08:52 PM
cav0011 the first time i mounted my vita's it felt like that, eventually i got it seated right and with a good amount of pressure applied to the bolt I was able to get it threaded.... never had a repeat of that issue ones I mounted them once though.
03-06-2013 08:43 PM
Burton mounting disc

Ok, so i just got my '13 Malavitas in today and when i try to use the 4x4 disc, it won't fully go all the way in to the baseplate no matter how much force i put, the screws won't reach the mounting holes, does anyone else have this problem with theirs?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

» Recent Discussions
Arbor Bryan Iguchi 156
Yesterday 11:36 AM
by Nivek
Last post by Nivek
Today 11:13 AM
13 Replies, 252 Views
New Front Page for...
11-23-2015 02:00 PM
Last post by VS Jeff
Today 11:08 AM
77 Replies, 2,367 Views
kirkwood 2016
11-07-2015 07:31 PM
by czoid74
Last post by KIRKRIDER
Today 10:37 AM
9 Replies, 383 Views
New site look and...
Today 09:56 AM
Last post by administrator
Today 10:35 AM
2 Replies, 59 Views
Which of these freeride...
11-29-2015 04:35 AM
Last post by neni
Today 10:33 AM
16 Replies, 460 Views
New edge tech: Sidecut...
Yesterday 10:12 PM
by jtg
Last post by SnowDogWax
Today 10:06 AM
6 Replies, 152 Views
backcountry Powder...
Today 09:51 AM
Last post by Argo
Today 10:05 AM
2 Replies, 41 Views
Snow Tires, are they...
11-05-2015 11:19 PM
by Rogue
Last post by Argo
Today 10:03 AM
154 Replies, 5,083 Views
Salomon, Rome, and...
Yesterday 05:01 PM
by tboylen
Last post by tboylen
Today 09:51 AM
2 Replies, 119 Views
replace laces or not
Today 08:53 AM
by dabears
Last post by Mystery2many
Today 09:51 AM
1 Replies, 71 Views
» Sponsors
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:20 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.