Snowboarding Forum - Snowboard Enthusiast Forums - Reply to Topic
Thread: Can't frontboard Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
04-11-2013 12:25 PM
Extremo Like the video says. Start on a flat box. 50-50 to shifty front board. This is exactly how I learned them. Soon enough you'll be jumping right into the front board position and coming out fakie. But I woulnd't take them to a rail until you can do all that on a box. You need to get comfortable getting the board all the way 90.
04-11-2013 12:04 PM
kev711 i have the same exact problem so i can't give advice from experience but i do know some pros and buddies that are jib rats. what everyone agrees on is get get shifties in that direction on lock. if you ride regular, punch through your left armpit with your right hand. strap on your board at home and practice to get the muscle memory.

this is the best "how to" vid i've ever seen.

let me know how it goes and what works for you. i can use the help too.
04-11-2013 11:43 AM
Can't frontboard

so there is this rail which I've been trying to frontboard but I simply can't. I can 50-50 very well, but every time I try to frontboard, I end up doing lopsided 50-50/feeble. I an trying to frontboard with counter rotation. another strange thing is I have trouble doing this even on boxes. plz help I am getting pretty pissed with myself!

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome