Snowboarding Forum - Snowboard Enthusiast Forums - Reply to Topic
Thread: New BOA Boots Not Staying Tight? Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 
   

Register Now



In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
01-06-2009 03:58 AM
Triple8Sol I actually go the DC Status this year, too. My first BOA boot. I've been experiencing the same thing as you. I keep them real loose until I'm about to get on the first lift. Then I snug them up. After the 1st run I'll tighten them again. I've used them 7x so far this season, and end up tightening them up again another couple times during the day. They're really stiff boots, so they're barely broken in at this point.
01-04-2009 11:29 PM
Dawg Catcher same here i own a set of 32s with the boa took me about three days on the mountain till they started getting set right. just stick with it worse case scenario put em on craigslist.
01-04-2009 11:11 PM
sacrifice it goes away. during the break in period you should flex them and as you come up from flexing tighten them up. like lean totally forward then as you begin to stand up straight tighten them up. this is what i had to do but now i LOVE my vans encores with boa.
01-04-2009 10:27 PM
JBW
New BOA Boots Not Staying Tight?

I just purchased DC status boots with the boa lacing system. They fit very well but kept coming loose the first and only day I have ridden them. I have to tighten them on every run. Is this the boot packing in? I have noticed that other boots with the same lacing system I have tried on will do the same thing after walking around for 10 or so minutes. Is this something I should be concerned with or will it go away after the initial pack in stage. I was interested in the quick lace system but will have to go with something else if this continues. Any help and experiences are appreciated.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome