Snowboarding Forum - Snowboard Enthusiast Forums - Reply to Topic
Thread: Burton Custom toe buckle losens Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 
   

Register Now



In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
01-06-2014 03:03 PM
vsavka no wear on the teeth. I did however had to replace the lead foot toe buckle and strap from excessive wear, but my rear foot dont show any wear/tear on the strap or the buckle
01-06-2014 02:04 PM
Psi-Man What do the ladders look like? Are the teeth chewed up?
01-06-2014 01:38 PM
vsavka
Burton Custom toe buckle losens

My 2009 Customs have an issue where the rear foot toe buckle losens up within 1 minute of riding, is this a common issue? does the buckle need replacement? plastic strap issue? (no signs of wear on the strap itself)

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome