Snowboarding Forum - Snowboard Enthusiast Forums - Reply to Topic
Thread: problem with burton binding disc Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 
   

Register Now



In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
03-20-2014 09:58 AM
Dago91
Quote:
Originally Posted by monkeytine View Post
It's just not cool when people belittle others for asking a question. Forums should be helpful. Sometimes people don't realize when they sound rude. (Posting a customer service number is borderline helpful but sometimes a forum is the best option for unbiased feedback and after operating hours for example.) Always remember: everyone was a noob at some point.
Point well taken
03-19-2014 08:34 PM
monkeytine It's just not cool when people belittle others for asking a question. Forums should be helpful. Sometimes people don't realize when they sound rude. (Posting a customer service number is borderline helpful but sometimes a forum is the best option for unbiased feedback and after operating hours for example.) Always remember: everyone was a noob at some point.
03-19-2014 06:04 PM
24WERD use 3 screws or return the board (seller pays returns)
03-19-2014 05:45 PM
Dago91
Quote:
Originally Posted by monkeytine View Post
No need to be rude. That's what this forum is for. And to be honest, Burton has the worst instruction manual ever so if they want people to quit having this problem they should update it. And if you have a problem with people asking "101" questions, then don't read them, and certainly don't take the time to respond to them just to make yourself feel better.
UMMMMMM I think he actually provided a phone number to help unlike you who just posted the above uselessness.
03-19-2014 04:00 PM
monkeytine
Quote:
Originally Posted by tonicusa View Post
Yes many people have had this issue. But most people are too busy to hold your hand through something this basic and snowboarding 101. Pick up the phone.
No need to be rude. That's what this forum is for. And to be honest, Burton has the worst instruction manual ever so if they want people to quit having this problem they should update it. And if you have a problem with people asking "101" questions, then don't read them, and certainly don't take the time to respond to them just to make yourself feel better.
03-14-2014 06:58 AM
JoeyOranges are you trying to get all of the screws threaded in an insert before cranking them all down or are you doing each individually before moving on to the next?

if the alignment is just a little off trying to get them all threaded first might help since the disc will still be able to move around a bit.
03-14-2014 06:37 AM
ekb18c Hey Dork, post some pictures! That will help.
03-14-2014 01:44 AM
ridinbend
Quote:
Originally Posted by OU812 View Post
Interesting, this problem seems to be more common than I thought. I'd return the board if I were you like I did. No reason to pay full price and put up with something that has a defect, thats what warrantees are for.
How is the board defective?
03-14-2014 12:40 AM
SonicSquirrel
Same Issue

Have a 2011-2012 Gnu Riders Choice. All stoked to throw my new 2013-2014 Cartels on there and I can't get all 4 to line up using the 4x4 discs provided by Burton. Hmmm...who might be at fault Burton or Mervin? I'm going with Mervin. Goofy bastards.
01-17-2014 05:30 AM
OU812 Interesting, this problem seems to be more common than I thought. I'd return the board if I were you like I did. No reason to pay full price and put up with something that has a defect, thats what warrantees are for.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome