Snowboarding Forum - Snowboard Enthusiast Forums - Reply to Topic
Thread: Issues with Rome 390's Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 
   

Register Now



In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
01-25-2011 06:13 PM
Triple8Sol Your ladder strap looks to be on backwards. The teeth should be on the outside.
01-25-2011 03:23 PM
ptapia
Quote:
Originally Posted by Boiler12 View Post
I was able to luckily figure it out, I gave up on the plastic strap part to pull it back though as I was just happy to get the clip down (plus I am sure I will be messing with the bindings after I take my board out on Saturday, which is sooner than I expected too). I ended up putting the high back down and angling that ladder and clip so I could push down on the high back and get it to snap. I don't think I'm Hercules or anything but I feel like I have a decent amount of strength and that was way to hard of a thing to snap into place.
I was worried about breaking this same thing on my 390 boss. I tried and tried and was worried about snapping the damn thing. I left it and thought about it for a while. I found that adjusting this strap when you have your boots on and are actually standing in the binding is easiest. You have much more leverage to snap in and as stated above, once you get it, it seems to be much easier. good luck.
01-25-2011 02:21 PM
Boiler12 I was able to luckily figure it out, I gave up on the plastic strap part to pull it back though as I was just happy to get the clip down (plus I am sure I will be messing with the bindings after I take my board out on Saturday, which is sooner than I expected too). I ended up putting the high back down and angling that ladder and clip so I could push down on the high back and get it to snap. I don't think I'm Hercules or anything but I feel like I have a decent amount of strength and that was way to hard of a thing to snap into place.
01-25-2011 02:09 PM
eug3fo That plastic clip is supposed to be connected to the straps right? I think it broke off... I dont see how you can fix that except to contact Rome Rep.
01-22-2011 06:46 AM
Leo Yea, it takes some force to lock the ratchet on that side with the plastic. You really don't have to use that plastic if you don't want to. Its purpose is to spring your ankle strap out of the way when you unstrap so it's not in the way when you are stepping in to strap in. Some people don't like this feature and cut off that plastic.

I really like the feature. You can make it tighter to make it spring further out of the way. Once you lock it, it will be easier to unlock/lock from there on.

I didn't have much problem locking it the first time, but I guess others do. Makes me feel strong
01-21-2011 10:28 PM
Boiler12 Did a little more searching (I swear I googled every combo of words I could find and even searched the forums) but finally was able to get an answer on google that led me here.

http://www.snowboardingforum.com/bin...t-close-2.html

Just need a little more force.
01-21-2011 09:58 PM
Boiler12
Issues with Rome 390's

Hey all, I just received my 390's today and went to mount them on my board and things went smoothly until I threw on my boots and went to strap in on the carpet to check for drag from the overhang.

I went to ratchet in the ankle strap and make sure it was tight but the strap popped off from the opposite side (the side shown in the picture). I tried to do a search to see if I was missing something and I also tried threading that rubber strap over the little catch there and then snapping that into place towards the front of the binding but I could get it to perpendicular and then it felt like I was going to snap the plastic.



This is the best way I can figure out how to describe what I am talking about, I can try again if it makes no sense.

Thanks for any help you can provide.

P.S. It does the same thing on the back binding as well.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome