Snowboarding Forum - Snowboard Enthusiast Forums - Reply to Topic
Thread: 2011 Rome 390's Ratchet Feedback Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 
   

Register Now



In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
02-02-2011 03:06 PM
jliu Does the paint chip for all colourways of the 390s?....or just the baby blue ones?

My black targas dont seem to have this issue.
02-02-2011 03:03 PM
WHOisDAN
Quote:
Originally Posted by Flat4Love View Post
when I spoke with rome the admitted a quality control issue with the highbacks hipping. They told me that they ID the problem and the factory has fixed it. They will send you new highbacks (at their expense) and say that they will 100% NOT chip in the future.
I emailed Rome about the paint chipping, and they said it was "wear and tear". Basically, it's not covered under warranty. Perhaps I should call them?
02-02-2011 02:53 PM
tahoe420 aaaaaaaaaaaaaa
02-02-2011 02:45 PM
Flat4Love
Quote:
Originally Posted by SHREDDER97 View Post
the only issue with mine is similar. when its cold the ratchet will not go into the grooves of the plastic piece. this could happened when u ride as well. My paint has chipped on my highback but thats about it . solid bindings just make sure u check them alot
when I spoke with rome the admitted a quality control issue with the highbacks hipping. They told me that they ID the problem and the factory has fixed it. They will send you new highbacks (at their expense) and say that they will 100% NOT chip in the future.
02-02-2011 02:37 PM
SHREDDER97
Quote:
Originally Posted by WHOisDAN View Post
I have Burton Imperial's and Rome 390 Boss bindings as well.

One of my ratchets randomly stopped working last weekend. I'm guessing that the ice caused it to malfunction because it started working after my board/bindings were dry on the way home. I was extremely nervous about losing my board on the lift. Regardless, I am going to contact Rome and ask for new ratchets.
the only issue with mine is similar. when its cold the ratchet will not go into the grooves of the plastic piece. this could happened when u ride as well. My paint has chipped on my highback but thats about it . solid bindings just make sure u check them alot
02-02-2011 02:33 PM
Flat4Love
Quote:
Originally Posted by WHOisDAN View Post
I have Burton Imperial's and Rome 390 Boss bindings as well.

One of my ratchets randomly stopped working last weekend. I'm guessing that the ice caused it to malfunction because it started working after my board/bindings were dry on the way home. I was extremely nervous about losing my board on the lift. Regardless, I am going to contact Rome and ask for new ratchets.
I just got off the phone with Rome regarding my binding issues, their warranty dept. is good and they stand behind their product.
02-02-2011 02:29 PM
WHOisDAN I have Burton Imperial's and Rome 390 Boss bindings as well.

One of my ratchets randomly stopped working last weekend. I'm guessing that the ice caused it to malfunction because it started working after my board/bindings were dry on the way home. I was extremely nervous about losing my board on the lift. Regardless, I am going to contact Rome and ask for new ratchets.
02-02-2011 11:35 AM
PortedBuckle Thanks for the feedback. I ordered them last week so should receive them today. I found a killer deal for 2011 390's for 147 bucks or so new. That's too bad that they are having some quality control issues.

I guess I should have commented that I am looking to getting into park riding a bit more, so that's why I have strayed away from the Burton C Bindings. I did have some 2005 Cartels, but the crazy forward lean (or maybe it was the wings on the sky highback giving me this weird calf pressure point) just was a bit much for me, and I think the Size Small that I got just didn't fit my boot right.

I am a small guy with size 8 boots (Burton Imperials with shrinkage as well), so I went with the 390 S/M size.

I'll post my thoughts after I get them mounted in today. I was afraid they'd be too sloppy, but I'll never know till I try. I was planning on a new setup next year, and worst case, I'll just pickup some 2012 bindings.

Why does it always seem that after I buy something, the mixed reviews start showing up in my searches?
02-02-2011 10:33 AM
ptapia I just got a set of boss's and I'm still not sure I'm sold completely, but I have a lot more riding to do with these and make a final decision. I have zero issues with the ratchets, unlike jliu, I tried to get something similar by trying a lot of different things, but nothing. Seems like jliu got some bad ratchets. As everyone says, the paint chips, this is just something we have to live with, not a big deal, but kinda shitty. As for me I'm a size 9 and I went with the L/XL. My boot is almost too small I think. I adjusted the heel hoop, and found the screw and its female nut, were cross threaded Not a big deal, still worked, I'll call Rome about this soon. Then it came to dialing in the straps. They're centered and they feel good for the most part. I've only gotten three days on these things, so maybe I just need a little more fine tuning or some break in. Either way the toe straps have to be about 3/4 over the top with a little toe cap. If its not this way it will just fall off. Then on my left foot I get a pain in my ankle by the end of the day from having the ankle strap tight. I did have some pressure points on my toes, but I got rid of those. Anyway, maybe I just need to keep fine tuning these. The performance of the binding is pretty solid for what I'm doing. Lots of response, flexy, and the cant system is very very cool. Pressing is so easy.

My thing right now is that last year I rode some cartels, loved them, bought myself a pair and I never really had any comfort issues with them. Even this year, I rode the cartels this past weekend and they still feel great. I went with rome because I had other issues with the cartels and I wanted to try something new. Everyone that had cartels seemed to like rome 390, boss, and targa. So I went with boss for the cant system.

To answer your question again, no ratchet issues. Anyway, hope my long winded experience helps.
02-02-2011 09:38 AM
jliu
Quote:
Originally Posted by PortedBuckle View Post
Hey everyone,

I am just getting back into riding after a few years off and am finally putting together some newer gear. I was still sporting some 2000 CFX's, a Burton Balance, and some Drivers. Anyhow, I have put my order in for some Rome 390s as I've heard so many great things about them, and I was suffering from some binding discomfort in the past. The question is....

Are there that many issues out there with the ratchets releasing randomly?

I could still change my order and get the latest cartels, but I'd like to give some other brands a try. Even going to grab a Never Summer SL to support a local Colorado company (not to mention it sounds like a sick ride).

Anyhow, just feedback on the ratchet issue would be greatly appreciated. Thanks!
Probably read my posting...heh. Yea mine release ridiculously easy. Rome is sending me new buckles...I have yet to receive them (a bit slow...but i guess its busy season). I'll keep the board posted if this solves the problem. My buddy has targas from 2008. I checked his rachets...same design...but the release leaver was "tighter" so small nudges wouldn't release the rachet. I rode his setup and purposesly didnt tuck my pant cuffs in...and had no issues. Hopefully its just my set. I think Leo had an issue with his boss's (I have targas). If you're buying your set from a store...play around with the rachets before you buy them to ensure they're not "loose".

Another issue is dumb forward lean lock...thing loosens so easily....mine actually broke off...waiting for Rome to respond. Dont want push you away from these bindings...cause a lot of ppl love them. I personally am not feelin the love right now...maybe when all these issues go away I'll like em.

Look into the Ride Deltas if this post scares you away.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome