Snowboarding Forum - Snowboard Enthusiast Forums - Reply to Topic
Thread: K2 Company/general binding question Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the Snowboarding Forum - Snowboard Enthusiast Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
01-02-2013 12:45 PM
Alex B Yeah, though they do make it a bit more fiddly! I think they're ok, the only problem is I can't get them started by hand so have to rely on getting the thread nicely located with a screwdriver, (risking cross-threading them)

Roughly how much thread do you get into your board?

Alex B
01-02-2013 12:40 PM
SnowRock I have these bindings and the disc fits into the baseplate fine. Are you using the "washers" and have those seated correctly as well?
01-02-2013 12:27 PM
Alex B Thats exactly what I'm thinking, it seems as though the teeth in the disk don't want to mesh properly with the baseplate, but I can't get them any better, wondered if K2 bindings were just a poor fit like that.

Yeah I'm against just getting longer screws as 1) I'm sure the supplied screws should work, 2) I don't want it to suddenly fit properly and the screw go through the base.

Alex B
01-02-2013 12:04 PM
snowklinger you don't have the binding disc properly set into the rest of the baseplate, something is off, or your are doing something else wrong.

getting longer screws is ignoring your problem and begging to destroy your deck.

sorry but more terrible advice look out.
01-02-2013 09:00 AM
Alex B Yeah they came with the bindings, off the board they seem to stick out the bottom plenty, but for some reason barely reach the inserts in the board, I was wondering if it was to do with the rubber pads on the side of the bindings making them sit off.

I'll do a little more fidling when I mount them properly.

Alex B
01-02-2013 08:36 AM
freshy Is it safe to assume your using the screws provided with the bindings, cause they should be he right size. If they are in fact too short it won't hurt to get longer ones.
01-02-2013 05:33 AM
Alex B
K2 Company/general binding question

I've recently tried mounting my new K2 Company bindings on my new Flow Drifter board, but the screws don't seem long enough. Unless I screw them in really hard, I can only get maybe 1 full turn on the screws, it's just into the locktite that came on them.

Anyone else found this, is that enough? I don't want to get longer screws and risk damaging the board, it's also looking likely that I won't get the chance to try the board before we go on holiday, so won't know if they're gonna work loose.

Alex B

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome