Snowboarding Forum - Snowboard Enthusiast Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Hi All,

Wanted some advise from others on this as I've never mounted bindings before, have a 2011 T.Rice Art of Flight Lib Tech board and some brand new Forum Republics.

I've mounted them to the board however it was quite a job, 3 of the screws seemed to go in easy however the 4th was consistently a little off, I had to tighten the screws a little and move onto the next one, tighten a little more and move on until finally all were screwed in. Noticed a few small bits of clear topsheet/fibreglass whatever it is come off where the thread of the screws must have cut it out.

The bindings are now on and seem very secure, they look to move a little at the tow and heel however I think this is due to everything being more flexible than my old setup which was stiff as board, stiff as bindings.

Is this process normal? Should it be a bit of an effort to get the bindings to fit? I notice the Republics are exclusive 4x4 bindings, the board is 4x but cant remember if 4x2 or 4x4. I just want to make sure, was thinking of taking into a shop to get them to fit the bindings again for me however we're off to Japan and I'll prolly need to set them back anyways....

Thanks all!
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
Will have to do it tonight and upload. Another detail - the baseplate on the bindings are split disc so they are in 2 halves that bend, thought this might have some impact on how it screws down

Edit - topsheet/fibreglass could be screwlock stuff or something too.
 

·
Premium Member
Joined
·
307 Posts
Will have to do it tonight and upload. Another detail - the baseplate on the bindings are split disc so they are in 2 halves that bend, thought this might have some impact on how it screws down
Your bindings will fit on a 4x2 or 4x4 board. The only difference between a 4x2 and 4x4 is that 4x2 has more holes giving you more stance options. So this part doesn't matter.

Sounds to me like a slight misfit caused by the camber of the board, but can't tell without pics. If you want it done right take it to the shop.
 

·
Registered
Joined
·
520 Posts
I had a few issues mounting my 390s on the exact same board. A small bit of top sheet (less than a pinky nails worth) came off and this was..3? months ago. Zero issues since then.
 
1 - 5 of 5 Posts
Top